要件と制約 - Android

提供: InterBase
移動先: 案内検索

Android アプリケーション へ戻る


  • InterBase は Android 4.x 以上を対象としています。この OS バージョンより前が稼働する Android デバイスは、サポートされていません。
  • Android 上の InterBase は、InterBase UDF および Filters をサポートしません。これは、すべてのサポート モバイル プラットフォーム(iOS と Android の両方)上の機能セットを、同じものにするためです。
  • Android 上の InterBase アプリケーションは、ネットワーク上のリモート InterBase サーバーへ接続する、ピュア「クライアント」モードとして動作することができます。 このためには、InterBase サーバー バージョンは、2009(9.x)以降でなければなりません。
  • Android 上の InterBase アプリケーションは、ODS バージョンが 13 以降の組み込みデータベース ファイルとのみ、接続することができます。 データベース ファイルが Android InterBase プラットフォーム以外からコピーされた場合には、InterBase バージョン 2009 以降で作成(もしくは復元)されたエータベースのみがサポートされる、ということになります。
  • ibconfig 制限: Android デバイスは、その他のデスクトップ/サーバー マシンと比較して、限られた RAM しか備えていないため、InterBase のフットプリントをより小さいサイズに維持するには、一部変更が必要となることがあります: これは、Apple iOS に対するサポートの仕方と同様です。
  • パラメータ DATABASE_CACHE_PAGES は、デフォルト 75 ページに
  • パラメータ SORTMEM_BUFFER_SIZE は、デフォルト 128KB に

次のトピック