RAD Studioをインストール時に、「CreateProcess エラー:コード 2 指定されたファイルが見つかりません。」というエラーが表示され、インストールできない
対象となる製品(指名ユーザーライセンス)
- RAD Studio XE8以降
- Delphi XE8以降
- C++Builder XE8以降
問題
RAD Studioをインストール時に、下図のように「CreateProcess エラー:コード 2 指定されたファイルが見つかりません。」というエラーが表示され、インストールできないことがあります。
同様のエラーが発生する原因として以下のケースが報告されております。
- 過去のライセンス情報が残っている場合に表示されることが多いエラーです。詳しくは、こちらを参照ください。
- Web登録ページからライセンスファイル(regXXXXX.txt)をe-mail経由で取得し、インストール時にライセンスマネージャでインポートした場合
本サポート情報では、このうち、2に相当するケースに関するエラーの原因と解決方法を詳しく解説いたします。
原因
RAD Studioのライセンス認証の手段には、いくつか方法があります。例えば、RAD StudioをインストールするPCがインターネットへ接続できない場合、別にインターネットへ接続可能なPCからライセンスファイルを取得する方法があります。オフラインの製品登録については、こちらを参照ください。
- Webブラウザで以下のURLへアクセスする
- お持ちのシリアル番号と登録コード、そしてEDNアカウントの情報を入力する
- 手順2の認証が完了すると、下図のようにライセンスファイル(regXXXXX.txt)をどのような方法で取得するか、選択できます。
- 2つの選択のうち、e-mail経由でライセンスファイル(regXXXXX.txt)を取得
上記の手順で、ライセンスファイル(regXXXXX.txt)を取得し、RAD Studioのインストール時にライセンスマネージャでこのライセンスファイルをインポートすると、下図のようにRAD Studioのインストールホームのbinディレクトリ内にbds.exeが配置されていないため、
結果的に「CreateProcess エラー:コード 2 指定されたファイルが見つかりません。」というエラーが発生します。
このエラーの原因は、上記の手順で取得したライセンスファイル(regXXXXX.txt)のエンコーディング形式がANSIになっていることに起因します。RAD Studioの旧バージョンでも類似した事例がございます。詳しくはこちらを参照ください。
解決
エンバカデロのライセンスファイルは、C:¥Program Data¥Embarcaderoフォルダに配置されております。 このライセンスファイル(regXXXXX.txt)をメモ帳などのエディタで開き、下図のようにエンコーディング形式をANSIからUTF(BOMなし)に変更し、ファイルを保存してください。
ライセンスファイル(regXXXXX.txt)のエンコーディング形式を変更後、
誠にお手数ですが、エラーが発生したRAD Studioを一度アンインストールし、RAD Studioを再インストールしてください。