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Introducing ER/Studio Business Architect

ER/Studio Business Architect (ER/Studio BA) is a tool for creating a graphical representation of
your business — from the core concepts that describe the business, to the processes that run
the business. ER/Studio Business Architect's Process Modeling capabilities allow you to easily
model your business processes and how those processes use data. ER/Studio Business Architect
Conceptual Modeling provides an intuitive way to outline subject areas and concepts that can
then drive the creation of detailed data models.

Through robust reporting, modeling, and graphical impact analysis, users are able to provide
relevant information to various stakeholders within the organization in a format that makes sense
to them. For example, a data analyst may wish to see a CRUD (usage) report showing what data
is used by a given process for compliance. A business user may want to see a list of relevant
business rules in a spreadsheet. A process modeler needs to see a semantically-rich process
model. ER/Studio Business Architect allows each stakeholder to see a different “slice” of
information, all from the same data source and metadata model.

Product benefits by audience

Business Process Modelers/Analysts: ER/Studio Business Architect provides a rich process
modeling semantic based on the Object Management Group's (OMG) Business Process
Modeling Notation (BPMN). In addition, modelers and analysts can link their business process
models with related business information such as business rules, stewardship, and data to
generate impact analysis and usage (CRUD) reports.

Data Modelers: ER/Studio Business Architect’s Conceptual modeling allows Data Modelers to
create a high- level design of the core business concepts to gain acceptance and
requirements from the business. These high-level Conceptual models can be forward and
reverse engineered with detailed Logical Data Models in ER/Studio. ER/Studio Business
Architect also allows data modelers to relate data objects to business process information,
and create Usage (CRUD) and impact analysis reports. In addition to process-specific
information, data can also be related to business information such as business rules,
stewardship, and business units.

Business Users: Conceptual Modeling allows Business Users to create high-level designs of the
core concepts and subject areas that drive the business, which can be passed onto data and
process modelers to drive more detailed logical and physical design. ER/Studio Business
Architect also provides intuitive reporting and export capabilities to provide relevant
information to business users in an easy-to-understand format. Intuitive impact analysis
diagrams and reports allow business users to get an understanding of the relationship
between business information and key IT assets such as data, without having to be a
modeling or programming expert. Information can be shared with business users in formats
they are familiar with: Excel spreadsheets, HTML reports, PDF files, etc.






New features

For the most recent set of new features for ER/Studio Business Architect, check the wiki at
http://docwiki.embarcadero.com/ERStudioBA/205/en/What%27s New in ER/Studio BA

Additional product resources

The IDERA Web site is an excellent source for additional product information, including white
papers, articles, FAQs, discussion groups, and the Knowledge Base.

Go to https://www.idera.com/er-studio-enterprise-data-modeling-and-architecture-tools, or
click any of the links below, to find:

e Documentation

e Online Demos
e Technical Papers



http://docwiki.embarcadero.com/ERStudioBA/205/en/What%27s_New_in_ER/Studio_BA
https://www.idera.com/er-studio-enterprise-data-modeling-and-architecture-tools
https://www.idera.com/support/productdocuments
http://trialcenter.idera.com/
https://www.idera.com/er-studio-enterprise-data-modeling-and-architecture-tools/resources

Installing ER/Studio Business Architect

Requirements

IDERA applications are 32-bit applications that run in a Microsoft Windows environment. Before
using ER/Studio Business Architect, verify that your environment meets these requirements:

Machine requirements

The following table outlines the minimum recommended requirements for installing ER/Studio
Business Architect:

e 1 GHz or faster CPU

e 4GB of RAM

e 2.5GB of free disk space
o 1024 x 768 display

Operating system requirements
e Microsoft Windows 7, 8, 8.1, 10

Installing ER/Studio Business Architect

This guide covers the installation requirements for ER/Studio Business Architect. Before you can
install any IDERA application, your environment must meet the application's minimum technical
requirements. After installation, you must license and register the application.

Installation wizard

The ER/Studio BA wizard-based installation guides you quickly through the product installation
process. This section explains the Installation Wizard and covers some basic decisions you must
make during installation. You must have administrative privileges to run the install.

CAUTION:  If you have a previous version of ER/Studio Business Architect installed, we
recommend that you uninstall it before installing the latest version of ER/Studio
Business Architect. However, you can run both versions because the new version
will install in its own directory.

Using the Installation Wizard

The ER/Studio Business Architect Installation Wizard automatically starts when you insert your
DVD or double-click your downloaded executable file. If you are installing from DVD and the
installation does not start automatically, start it manually by double-clicking the file setup.exe, at
the root of the DVD directory.

Once the install starts, there may be a brief period of time when nothing appears to be
happening. The runtime environment is being initialized.

View the ER/Studio Business Architect’s Software License and Support Agreement by clicking
the license terms link in the window. Check | agree to the license terms and conditions, and
then click Install to continue the installation process. Installation cannot continue without
checking the box indicating that you agree to the license terms.

The Options button allows you to access the Setup Options window where you can select to use
the default directory, change the existing directory, or create a new directory. Once you make
your selection, click OK to return to the licensing agreement window.
NOTE:  The default directory is x:\Program Files\IDERA\ERStudio Business Architect x.x.x.
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NOTE: The installation may take several minutes. A progress screen displays what files are
being installed and the percentage of completion.

Once setup is complete, a successful message appears. Click Launch to open ER/Studio
Business Architect.

Upgrading ER/Studio Business Architect

For Workstation license installations, version 16.5 and later require new serial numbers. Obtain
new serial numbers from the Maintenance Portal.

For Networked license installation, obtain new ER/Studio Business Architect 16.5 and later
license certificates from the Maintenance Portal. Please ask your /icense server administratorto
host the new license certificates.

If you have an existing version of EA/Studio or ER/Studio Business Architect, the new version
installs to a new directory labeled for that specific product name and version by default.

NOTE: The setup program looks for existing user preferences previously set on the machine.
These settings are automatically applied to the new installation configuration.

CAUTION:  If you have installed the newer version of ER/Studio Business Architect, your
workspaces must be upgraded before they can be used. Therefore, it is not
recommended to keep both versions on your computer as workspace files are not
always compatible.

Uninstalling ER/Studio Business Architect
Uninstall ER/Studio Business Architect 2016 and later

To uninstall ER/Studio Business Architect 2016 or later, use Microsoft’'s Add or Remove
Programs option to remove the application. This opens the InstallShield Wizard for uninstalling
the application. You have the option on the Remove Preferences panel to remove all
preference data from your computer. If you choose to leave the preferences, they will be used
for future installs.

The workspaces and all user-created projects, models, diagrams, and elements are not

uninstalled. These workspaces typically reside in a different directory and are not removed.

NOTE:  You can also uninstall by going to Start > Programs > IDERA ER/Studio Business
Architect X.X.X > Uninstall > Uninstall.


https://maintenance.embarcadero.com/
https://maintenance.embarcadero.com/

Uninstall ER/Studio Business Architect 1.7.2 and earlier
To uninstall ER/Studio Business Architect 1.7.2 and earlier so you can install a later version:

1. Click Start > Programs > IDERA ER/Studio Business Architect x.x.x, and then Uninstall
ER/Studio Business Architect. ER/Studio Business Architect opens the Uninstall Wizard.

2. You can select to uninstall all or part of the products. The separate components are:
Program Files, Help Documents, and Common Components.

3. Complete the wizard panels, and then click Finish. ER/Studio Business Architect and all its
components are uninstalled.

NOTE:  During uninstall, you have the option to remove all preference settings. If the settings
are removed at this time, all the preferences you have set are lost for future installs.

NOTE: The workspaces are their related projects, models, and diagrams are stored in a
different directory and are not uninstalled.

Licensing ER/Studio Business Architect

ER/Studio Business Architect requires a valid license in order to run. The kinds of licenses are:
Trial licenses: A license for a 14-day, full-featured trial version of the product. The trial license
must be registered before you can use the product.

Workstation licenses: A license or set of licenses that is tied to a particular workstation. If the
licensee has purchased a single seat license, licensee may install the product on one computer
for use by one end user.

Networked licenses: Networked licenses are administered and distributed by a central License
Server (IDERA License Center, Appwave, or Acresso FLEXnet Publisher). There are two types of
networked licenses:

e Concurrent. Users on different machines take turns using licenses from a shared pool.

e Networked Named User. Licenses are pre-assigned to specific users that are set up on
the license server's user list. Those users are guaranteed licenses available any time.



Upgrading your license

ER/Studio Data Architect editions, Enterprise Team Edition 2016 (or later) and pre-2016, and
ER/Studio Business Architect licenses

Type/Version

ER/Studio Data Architect
Editions and Enterprise Team
Edition 2016 (or later) Client
License

ER/Studio Architect
Editions and Enterprise
Team edition Pre-2016
Client License

ER/Studio Business
Architect All Licenses

Workstation

ER/Studio 19.0.x uses the
version 2016 serial number.
Have end users perform the
“Update..."” function in the
License Manager to generate
a 19.0.x license. Note that
version 18.0.x must be
installed on the same machine
as 2016 and 2016+. There is no
need to go to the
Maintenance Portal.

Obtain your 2016 serial
numbers via the
Maintenance Portal.
Provide 2016 serial
numbers to your end
users, and they will

install and activate 19.0.x
products by using the
2016 serial numbers.

Version 19.0.x uses the
same serial numbers as the
2016+ version. If you have
a 2016+ serial number,
register it again on the
same machine. The
updated license includes
the 19.0.x version. If you
do not have the 2016+
serial number, obtain it
from the Maintenance
Portal.

NNU/
Concurrent

Your license server
administrator must update the
existing license certificates to
obtain the 19.0.x license. End
users need a new slip file from
the license server
administrator.

Obtain your 2016
certificates from the
Maintenance Portal.
Your license server
administrator must host
them and send end
users a new slip file.

Obtain new ER/Studio
Business Architect 19.0.x
license certificates from
the Maintenance Portal.
Please ask your licensee
server administrator to
host the new license
certificates.

If you encounter a discrepancy with license counts or have issues retrieving your licenses,
please email EMBTProductUpgrade@embarcadero.com.

ER/Studio Team Server 2016 (or later) and Pre-2016 licenses

Type/Version

ER/Studio Server 2016 (or later) License

ER/Studio Team Server Pre-2016 License

Workstation

Maintenance Portal.

Version 19.0.x uses version 2016 serial
number. There is no need to go to the

Obtain your 2016 serial number from the
Maintenance Portal. Uses that serial

19.0.x.

number to activate Team Server version

If you encounter a discrepancy with license counts or have issues retrieving your licenses,
please email EMBTProductUpgrade@embarcadero.com.
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Tutorials

These tutorials are intended to help you get started using ER/Studio Business Architect and
give you the foundation you need to explore its many features and benefits. You will learn how
to create a new business process and conceptual model, format and edit diagrams, import and
export data, and generate a web report. You will also become familiar with some frequently
used tasks and commands to make you more productive.

This guide is divided into short, easy to learn sessions. Do them all at once, or complete them
individually as you have time.

Session 1: Getting Started with ER/Studio Business Architect
Session 2: Understanding the ER/Studio Business Architect Infrastructure

Session 3: Creating a Business Process Model Diagram

Session 4: Creating a Conceptual Model Diagram

Session 5: Exporting Conceptual Diagrams to ER/Studio Data Architect

Session 6: Importing an ER/Studio Data Architect Model to a Conceptual Model

Session 7: Creating a Diagram from Selected Elements

Session 8: Importing External Data Objects from ER/Studio Data Architect
Session 9: Exporting External Data Objects to ER/Studio Data Architect
Session 10: Using Reference Objects

Session 11: Using the Grid Editor

Session 12: Exporting Data

Session 13: Importing Visio Models

Session 14: Importing Comma Separated Value (CSV) Files

Session 15: Creating Links and Impact Analysis Diagrams

Session 16: Creating Usage Relationships

Session 17: Collaborative Modeling
Session 18: Using the Web Report
Session 19: Using ER/Studio Business Architect Tools

You can use this basic guide as a roadmap of product highlights, but it also is provided to help
you find your own path in exploring ER/Studio Business Architect.

Once you've started, you can select Help from the menu to find many additional resources that
complement and build on many of the activities shown in this brief guide.
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Session 1: Getting started with ER/Studio Business
Architect

The following graphics illustrate the main elements of the ER/Studio Business Architect
Application User Interface. The first graphic shows a Business Process Model workspace,
project, model, and diagram. The available palette is in the Business Process Objects.
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The second graphic shows a Conceptual Model workspace, project, model, and diagram with a
Conceptual Objects palette.

NOTE: The available palette depends on the type of Model, that is, if it is a Conceptual
model, only the Conceptual Objects palette is available.

() ER/Studic Business Architect - Waterfront Bank.sxw =Iml =B
| File Edet View Repostery Diagram  Format Took  Window Help |
XD ws »8a0-~-0-~@-m-B~-B-rO~O g e r B e deBl—-  ~-nHhEHT=Y,
EIHI'[IQ B-—--'Qavi'uurj./r_"uiu 1 B SR E
Ell.n'ul.\-‘h-«:a- s HINE @@
5 Model =2 = [ | [H customer Conceptust .. =
slEE i b
4 [ Waterfront Bank a
# B Enterprise Architecture Initistive | |
+ f§ Business Concepts
4 [ Customer Conceptual Dil Party
a [l Aceount | ( 3 f ™
& Status b | Person Salary
& Tox Identifiar Name Amount
& Amount ?r\:'w I Pada Effectve Date
& Name | TRV T |
& Description
4D Incoming Relstior
[ Geographic Location
NI— —
D Paty
Salary
[&] Title for Customer Co —— —
<] High Level C
%hzou:z s Geographic Location
Hame
[ Customer Abbreviation
[ T T, R | I S A — Ny —_—— Descrintion =
" ¥ . i v
T Overview I3 = 1 | [ Customer Conceptual Diagram | @ Status I aam;c”mu' My en
I i 0 Business Attribute: Status
. =0 s riter o [ (=] ;
(CRUD) + [ Workspace Hierarchy
------ = a4 I Waterfront Bank
Impact Anahysly E\ Erterprise Architecture Initiative
4 & Disaram Usaae |1 =)
Medel View Filter: OF

12



Session 2: Understanding ER/Studio BA infrastructure

Before we begin, let's cover some of the basic constructs that help organize and display the
information in ER/Studio Business Architect:

Workspace: The workspace is the top-level container or owner of your projects and reference
objects. You can only have one workspace open at a time.

Project: The Project is a collection of items relevant to a customer including models, model
objects, documents, business rules, etc. For example, a “Human Resources” project might
contain a business process model describing the main functions of the Human Resources
department, business rules describing the behavior of the organization can be created as
reference objects and referred to in the project. You can nest a project within an existing
project, where one project is parent of another project. A project need not contain a model,
but is most commonly used to organize groups of models. You can have multiple projects in a
workspace. However, a project is not required. You can nest models directly under a workspace
without using a project to organize them.

Model: A model is a specific collection of elements/objects related to a modeling notation
(Business Process Modeling Notation [BPMN], Conceptual, etc.). For example, the Human
Resources BPMN model would contain those objects associated with the business processes of
HR: tasks, swimlanes, gateways, etc. A model is where the object “lives;” objects are stored
within a model but can be visualized in other formats such as a visual diagram and grid editor.

Diagram: A diagram is used for creating graphical models of business operations. The main
types of diagrams in ER/Studio Business Architect are Business Process and Conceptual Model.
The third diagram type, Impact Analysis, displays the relationships you created between
objects.

Business Process Model Diagram. A Business Process Model is a visual representation
of the flow of activities and their order of performance using a set of graphical elements
that use shapes familiar to most modelers and business users. For example, activities are
rectangles and decisions are diamonds. The result is having an easy-to-understand
mechanism for creating business process models which produce complex business
processes.

Conceptual Model Diagram. Conceptual modeling is used by enterprise architects,
business users, and data architects to model high-level business concepts and subject
areas. A common usage of a Conceptual Model is to relate the model to a Logical Data
Model. However, it could include other elements like data flow, process, or information
assets in addition to more abstract interactions between business “things” like areas of a
business and their associations, such as the association between Sales and Finance
organizations.

Impact Analysis Diagram. The Impact Analysis Diagram is a graphical representation of
the relationship between various objects based on links you create to form relationships.
This diagram is discussed in Session 15.
Object: An object is a generic term for items or elements that make up business processes and
conceptual models: tasks, swimlanes, gateways, flow objects, business entities, business
attributes, etc.
In the following pages, we'll use ER/Studio BA to create sample business process and
conceptual modeling diagrams. We will also use reference objects, the grid editor, and the
import/export framework, as well as create links and usages, create an Impact Analysis
Diagram, and view Impact Analysis and Usage (CRUD) reports.
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Beginning to model with ER/Studio Business Architect

1. From the Start > Programs menu, choose IDERA ER/Studio Business Architect X.X >
ER/Studio Business Architect and the Welcome dialog opens. You can also double-click
the ER/Studio Business Architect shortcut that is placed on your desktop at the time of
installation.

Welcome to ER/5tudio Business Architect L—S_"hj

Welcome to ER/Studio Business Architect
Welcome to ER/Studio Business Architect. What would you like to do?

(@ Create a new workspace (with optional project, model, and diagram)
[l Express create: Business Process

() Import a compressed workspace
Open my last used workspace

(7) Open an existing workspace:

™
)

() Get a workspace from the Repository

[] Always use last workspace on startup

@ T ——

L. A

2. Inthe Welcome dialog, select Create a new workspace (with optional project, model, and
diagram).

NOTE:  You can also use the express create method. If you select this option, you only
need to select the model type and enter a name. A workspace, project, model,
and diagram are then created for you, all with the same name.

Click OK and the Create a New Workspace dialog opens.

4.  For purposes of these tutorials, take the following steps to create a new workspace, project,
model, and diagram:

. Enter the workspace name “Acme Company” but leave the default directory as is.

o Enter the new project name “Compliance Reinstatement Project” under Project
options.

. Create a new model named “Shipping Process Model” within the project you just

created. Leave the Model type as Business Process and leave the default setting as
On for the Validate against BPMN specification setting.

. Create a new diagram named "“Order Picking” within the model you just created. As
you enter the name of the diagram, the Name of Pool with Invisible boundary and
First lane name text boxes are populated with the same name.

5. Rename the pool name as “Order Picking Pool” and rename the First lane name as “Order
Picking Lane.”

14



MNew Workspace ﬁ

Create a New Workspace

Workspace name: ACME Company

Workspace directory: Ch\Users\npollard\Documents\ERStudioBusinessArchitect -

Workspace will be created at:

C\Users\npollard\Documents\ER5tudioBusinessArchitect ACME CompanytACME Company.exow

Project options
Create a project within this workspace

Project name:  Compliance Reinstaternent Project

Model options

Create a model within:

Model name:  Shipping Process Model

Model type: [BusinessProcess v]

Validate against BPMM specification: [No Validation -

Diagram options
Create a diagram within this model
Diagram pame: Order Picking

MName of pool with invisible boundary:  Order Picking Pool

First lane name: Order Picking Lane

® [ 0K ] [ Cancel l

L

6. When you click OK, a new workspace, project, model, diagram, pool, and lane are created
and appear in the Model View. The items are displayed in the hierarchal mode in the tree.

) *Model SlEpE AR O
4 [ ACME Company <€ Workspace
4 @- Compliance Reinstatement Project€— Project
4 ﬁ Shipping Process Model €——— [\ladel

Order Picking €——————— Diagram

4 [ Order Picking Pool ¢=———— Pool with Invisible Boundary
== Order Picking Lane €——— First Lane
- [}, Reference Objects
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When working with Business Process models, you work with processes. A process is a
collection of flow objects connected by flows that is executed in a sequence (usually
depicted on a diagram). In the Business Process Modeling Notation specifications, all
processes are contained by a pool. A pool contains only one process, but you can have
multiple pools in a diagram which can then collaborate via messages.

To display a process in the Model View tree, go to Window > Preferences > Business
Process Modeling > Processes. Select the option to Show processes in application, and
then click OK. Now the elements in a diagram or pool are displayed under the Process

node (WE) in the Model View.

B *Model & H|BE
4 ACME Cormpany
4 @- Compliance Reinstaterment Project
4 ﬁ Shipping Process Model
Order Picking
4 [ Order Picking Poaol

of Order Picking Pool «—— Process Node
=2 Order Picking Lane
- [} Reference Objects

[E = o

Reference Objects are also created at this time. For more information, see Session 10:
Using Reference Objects.

In the Model View you have toolbar commands that make it easier to work in the tree.

Icon Command Description
P Refresh Updates all the nodes in the Model View.
Collapse All Collapses all the nodes in the Model View.
& Expand All Expands all the nodes in the Model View.
Sync with Diagram If this command is selected, whenever an
3, element in the diagram is selected, the Model
View automatically selects that element in the
Model View.
\_fEI Filter Opens the Model View Filter dialog.
E' Group by Object Groups items in the Model View by element

type. This is a toggle switch.




Using the Model View

The Model View displays the hierarchy of workspaces, projects, models, diagrams, and

elements. It also displays the hierarchy of reference elements. In the next step of this evaluation

guide, we are going to create a new project that will be nested in an existing project.

1. Right-click the Workspace node labeled “Acme Company” in the Model View, and then
select New > Project.

2. Inthe New Project dialog, enter the new project name “Compliance Reinstatement Project
Part Two.”

3. Inthe Select where you want to create the project text box, select Compliance
Reinstatement Project.

’ =)

Mew Project

Create a Project

Enter a name for the project.

Project name:

Compliance Reinstaternent Project Part Two

Description:

Select where to create the project:

4 ACME Cormpany
@- Compliance Reinstaternent Project

@' (0] 4 l ’ Cancel

A

L

4. Click OK and the newly-created project is placed in the Model View nested under the
Compliance Reinstatement Project node.
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Session 3: Creating a business process model diagram

We will create elements for a diagram three different ways: using the palette in the Diagram
View, using the Toolbar, and creating elements in the Model View.

Creating elements in the Diagram View

You can build a business process model diagram by placing elements in the Diagram View
directly from the Business Process toolbar. The diagram we are going to create shows the
business flow of filling an order in a warehouse for shipping.
B Model 22 S| EB(E)|MAE=O
Fi ACME Cormpany
4 @ Compliance Reinstaternent Project
4 ﬁ Shipping Process Model
a4 COrder Picking
@ Start Event
4 [ Order Picking Poaol
F Dﬁg Order Picking Pool
4 O Start Event
@ Message Trigger
=2 Order Picking Lane

@ Compliance Reinstatermnent Project Part Two
- [, Reference Objects

1. On the Business Process toolbar click the drop-down arrow next to the Start Event icon (@).

2. Click the Message Start Event icon (@) and then click once on the left-hand portion of the

Diagram View. This message event indicates that the process must receive a message from
an outside source before the event can start.

NOTE: The cursor is in multi-drop mode (%El) allowing you to place as many elements
as you need. Press ESC or click the right mouse button to exit the multi-drop

mode. The cursor changes from X to . You can disable the multi-drop

option by going to Windows > Preferences > Diagrams and deselect the
Enable multi-drop on object creation option.

In the Business Process Modeling Notation specification, all business process
diagrams must contain at least one pool. A pool and lane with an invisible
boundary were created when you created a new diagram. The pool with the
invisible boundary is indicated by the £ icon in the Model View. In ER/Studio
Business Architect, when you place an object in the diagram, that object is placed

in this invisible pool. This invisible pool becomes visible when you drag it to
another diagram in the Diagram View.
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MDdeIE@ ¢¢|E'ﬁE|:EI
Fi ACME Company
4 @- Compliance Reinstatement Project

A i ST Ll odel
Order Picking

Fi Oﬁz Order Picking Pool
Fi O Start Event

@ Message Trigger
== Crder Picking Lane

@- Compliance Reinstatement Project Part Two
- [} Reference Objects

The start event is shown as a presentation element under the Diagram node (this
is indicated by an arrow decorator placed on the icon ).

Ml:udeIEE $¢’|E|'EIE|:EI
Fi ACME Company
4 @- Compliance Reinstaterment Project
Fi ﬁ Shipping Process Model
a Crder Picking

a [ Order Picking Pool
4 Oﬁz Order Picking Pool

@ Message Trigger
= Order Picking Lane

@- Cormpliance Reinstaternent Project Part Two
- [}, Reference Objects

The pool with the invisible boundary that you named at the time of the new
workspace creation appears in the Model View hierarchy. In this case it is called
Order Picking Pool. The pool contains the Process ( ) and all elemgnts
placed in the diagram.

You have the option to display labels on elements. Right-click the start event on the
diagram and select Show Name. You can also set a display option preference for each
element type that automatically shows the label when you create an element.

To open the Formatting Preferences dialog, do the following:
a. From the main menu select Window > Preferences.
b. Expand the Formatting node and select Business Process Modeling.

c. Select the element you want to set the preference for in the list box, in this instance the
End Event.

d. Under the Diagram Display Options section, select Show name on creation, click
Apply to Diagram, and then click OK.
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4.  Click the Task element (= ) on the Business Process Objects palette and place four tasks
in the Diagram View as shown in the following graphic.

#

Task Task1 Task2

Start Event

Task3

T ——————

5. Next we will label the tasks. You can double-click a task element, enter your label, close the
Task properties window, and then go on to naming the next task. Label each task as
follows:

. Task = Check Order

. Task1 = Check Inventory

o Task2 = Confirm Order Pull
. Task3 = Handle Fault

Aligning in the Diagram View

There is a quick and simple way to align your placed objects. In this example we want to make
sure our top set of tasks are aligned and distributed evenly.

1. Select the three tasks you placed at the top of your diagram by holding down the left
mouse button and drawing a box around the tasks. Notice that all three tasks are now
marked with handles.

2. Place the mouse cursor on the task labeled “Check Order” and Shift + Click because you
want to align all the other elements with it. That element is now highlighted with black box
handles instead of hollow boxes.

:
Check Order =
Start Event Check Imventory
= Check Order Pull

Handle Fault
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3. Select the Align Top icon ( “f7) from the Alignment toolbar and the three tasks are now

aligned.

4. With the same three tasks selected, click the Distribute Evenly icon ((Hl) and the three tasks
are evenly distributed horizontally.

Grouping elements in the Model View

You can group elements by object types in the Model View. This is a toggle button available on
the Model View toolbar. When this button is selected all diagrams and elements in the Model

View are grouped by type.
4@y ©

B “Model 2 & B E
4 ACME Company

Fi E Compliance Reinstaterment Project

4 ﬁ Shipping Process Model

4 Order Picking
@ Start Event
& Check Inventary
» 0 Check Order
Check Order Pull
&4 Handle Fault
4 [ Order Picking Pool
4 Oﬁz Order Picking Pocl
a O Start Event

@ Message Trigger 8
4 ] b

m

e Click the Group by Object Type button on the Model View toolbar ( EI).
e Thelist is now grouped by type and each type node is indicated by a folder indicator (
&),
e For purposes of these tutorials, we are going to click the Group icon once again to
ungroup the elements.
Filtering

You can use the filter to hide or show modeling elements, reference objects, data objects, and
shapes in the Model View. You can filter out elements based on a general type, or a specific
element. A status bar located in the lower right-hand corner of the application displays the
status of the filter (off or on).
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1. Click M in the Model View toolbar to open the Model View Filter dialog. We are going to
filter out several of the items listed in the Reference Objects node.

ral %
Model View Filter e

[ Text filter (only matching names will be shown)

Select the types to be included in the model view:

4 [J] @ Business Process Modeling »
Business Process Diagram
Irnpact Analysis Diagram
[7] o Process
() Start Event
@ Intermediate Event
[¥]@ End Event
™ Task A
B Embedded Sub-Process
B Reusable Sub-Process
[ <» Gateway
{ Conversation
B Chorecgraphy
[/] == Participant
& SubChoreography
[¥] == Participant
[¥]E= Pool
[¥]== Lane
[E] Data Object
[ Message Item
C Annotation
[¥]£0% Group
[]—# Sequence Flow d

ENENEIENE

m

@ [ ok [ Caned |

L A

2. In the Reference Objects node deselect Business Rule and Business Unit. All the other
types should be selected.
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3. Click OK and the only items listed in the Reference Objects node, in addition to the
External Data Objects node, are Business Elements, Domains, and Stewards. The Model
View tab displays the information that the Model View has been filtered.

5 *Model (Filtered) 52 = g

$| B B &
4 ACME Company

4 @- Compliance Reinstatement Project
a ﬁ Shipping Process Model
> Order Picking
» 1 QOrder Picking Pool
@ Compliance Reinstaternent Project Part Two
a [ffi| Reference Objects

el Applications
& Business Elements

E]] Domains

By Stewards

Creating an element in the Model View

You can create an element in the Model View from any pool node. A diagram is not required to
create elements.

5 Model (Filtered) &2 = B

| B EE B

4 ACME Company
4 @- Compliance Reinstaternent Project
P ﬁ Shipping Process Medel
4 Order Picking
@ Start Event
& Check Inventary
» 0 Check Order
0 Check Order Pull
74 Handle Fault
4 [ Order Picking Pool
4 0<E Order Picking Pool
» O Start Event
[ Check Inventory
» [ Check Order
[ Check Qrder Full
[ Handle Fault
== Order Picking Lane
E- Compliance Reinstaternent Project Part Two
4 [fl}y Reference Objects
? External Data Objects
Ed Applications
&P Business Elements

gl] Domains

% Stewards
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1. Right-click the Order Picking Pool Process node that is a subnode of the Order Picking
Pool in the Model View.

2. Select New.

3. From the list of BPMN elements, select the element you want to create in the Model View.

In this case, select the End Event element (9). The element is placed in the Model View
but does not appear in the diagram.

4. Once you create the element in the Model View, drag it on to the Diagram View and place
it to the right of the task labeled “Confirm Order Pull.” Notice that the End Event's name
automatically shows because of the preference you set earlier.

Check Order Check Imventory Cﬂnﬁ::rz:l:arder O
Start Event End Event

Handle Faukt

Changing the properties of an element

When you double-click on an element, the Property View for that element opens. You can use
the Property View to:

e Change the name or properties of an element.

e Enter a description and notes for the element, if applicable.

e View any links or usages that have been created to the element.
e View the Impact Analysis report.

e View the Usage (CRUD) report.

e Change the appearance of the object.

For purposes of this diagram, we are going to rename the End Event and change the Results
type to a Message End Event.

@ OrderFilled 22

b3
&
@ End Event: Order Filled g
7
?
General Type MName Properties C
Description Message  Message.. Implementati.. )
\L‘-.
MNotes
riggers =
Assignments K\)
Links ;
Usage (CRUD) >
Impact Analysis N
Appearance

AV,

Parallel Multiple ®) @I

24



1. Double-click the End Event object in the Diagram View to open the Property View.

2. On the General tab, change the name to “Order Filled.”

3. Click the Results tab and then click the Message icon (®). The End Event is now a
Message End Event.

4. To place a second Message End Event in the diagram, expand the Business Process
Objects palette and click the drop-down arrow to the right of the End Event icon.

5. Select Message End Event from the list and place it to the right of the Handle Fault task in
the diagram.

6. Rename this End Event “Fault Resolved” by clicking once on the End Event label to change
it to an editable field.

Check Order Check Inventory c“"ﬁgﬂlf"de' @
Start Event Order Filled

Handle Fault

Fault Resohved

We are going to place an error intermediate event on a task which shows that if an error
occurs, the flow will take you to the Handle Fault task where the error will be corrected.

7. On the Business Process palette, click the drop-down arrow on the Intermediate Event icon
(@') and select the Error Intermediate Event (®) from the list.

Check Order

8. Place the event on the lower edge of the task labeled Check Order. The icon is now
docked to the task.

Connecting the elements

There are three different types of connectors used in the Business Process Modeling Notation:
Sequence Flow, Message Flow, and an Association.

To complete our diagram, we are going to use the Sequence Flow connector to connect all
elements in the diagram.

1. Click the Sequence Flow icon (=*) on the Business Process Toolbar.
2. Draw sequence flows between the following elements:
o Start Event to Check Order task

. Check Order task to Check Inventory task

. Check Inventory task to Confirm Order Pull task
25



o Confirm Order Pull task to

o Order Filled end event

o Error Intermediate Event to the Handle Fault task
o Handle Fault task to Fault Resolved end event

This completes the process of creating the business process diagram. Your diagram
should resemble the following graphic.

Check Order Check Inventory Cﬂl'lﬁgnu"()rder
Start Event Order Filled
Handle Fault
Fault Resolved

The Model View now displays the outgoing or incoming relationships for the elements.

S Model (Filtered) 52 = e =0
F] ACME Company -
4 @- Compliance Reinstaternent Project
F] ﬁ Shipping Process Model
> Order Picking
4 (] Order Picking Pool
4 OE Order Picking Pool
Fi O Start Event

% O~ Outgoing Relationships
4 — Start Event.Check Order
[ Check Crder

. (@) Interrmenms
, @ Intermediate Eventl
. (@ End Eventl

4 (@ Fauk

4 LI Incoming Relationships

m

4 —# Handle Fault.Fault Resolved
[ Handle Fault

(=) e,
. (@ OrderFilled
> [ Check Inventory
» [ Check Order
» [ Check Order Pull b
» [ Handle Fault

== Order Picking Lane

@ Compliance Reinstaternent Project Part Two

4 [fff, Reference Objects i

Using the Impact Analysis Report
The Impact Analysis Report can be viewed for most nodes on the tree.

1. To view this report right-click the End Event labeled “Fault Resolved” in the Order Picking
Pool node.
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@ Fault Resolved &3

@ End Event: Fault Resolved

General Filter OFf
Description
Notes 4 Workspace Hierarchy

- 4 ACIVIE Company
i == > @- Compliance Reinstatement Project
Assignments 4 &5 Diagram Usage
Links Order Picking
Usage (CRUD) 4 lig Heritage

5 a fj Parent
Impact Analysis °<Z Order Picking Pool
4 ) Children

@ Fault Resolved.Message Trigger
4 Yo Incoming and Outgoing Connecting Objects
4 @ Business Process Objects
> —# Sequence Flows

NN NS TN

2. Select Impact Analysis > Show. The Property View opens for the selected end event with
the Impact Analysis tab opened in the view.

The report shows the following interrelationships between elements in the Model View:
. Workspace hierarchy

o Diagram usage

o Heritage

. Incoming and outgoing connecting objects

3. You can view this report in a tree or table format, with tree as the default. To view the

report in the table format, click & located next to the Filter indicator. Double-click on any
row to open the Property View for the selected element type.

0 Fault Resohved &2 A <=

@ End Event: Fault Resolved

General Filter Off |E;J

Description

Notes Impact Topic Element Type MName Target Element Type Target Element Name
Triggers Workspace Hierarchy Workspace ACME Company
Assignments Workspace H?erarch)r Project Co.mpillance Reinstate...
U Workspace Hierarchy Model Shipping Process Model

inks Diagram Usage Diagram Order Picking
Usage (CRUD) Parent Heritage Process Order Picking Pool
Impact Analysis Child Heritage Message Trigger Fault Resolved.Messag...

Connecting Object Sequence Flow Handle Fault.Fault Res...  Task Handle Fault

BEEEC0E
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Using the Impact Analysis Filter

1. In the Impact Analysis click Ao open the Impact Analysis Filter dialog. There are two
tabs: Relationship Types and Object Types. In Relationship Types you can select the types
of relationships you want included in the impact analysis. In this exercise we will filter out
the Incoming and outgoing connecting objects.

Impact Analysis Filter %

Relationship Types | Object Types

Select the types of relationships to be included in the impact analysis:

Workspace Hierarchy
s Diagram Usage I
a [J]{J§ Heritage
i} Parent

[¥] @ Children
a [|%3+ Incoming and Outgoing Connecting Objects

4 Dsﬂ Business Process Objects
[] o Associations
[] b Message Flows
[]—# Sequence Flows
[[] = Conwversation Link
4[] Conceptual Objects
[]+ Relationships
[]—# Interactions
4 [} Lines
[]  Lines
Links il

BDEE

™

L3

m

Dl

@ [ ok || cancel |

#

L

2. In Object Types, all object types are in a collapsed list under this tab. You can select the
entire group or select individual elements within that group. On the Objects Types table,
we will filter out the External Data Objects.
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- A
() Impact Analysis Filter ﬁ

| Relationship Types| Object Types

[] Text filter (only matching names will be shown)

Select the types of objects to be included in the impact analysis:

ﬂ Business Process Modeling
& Conceptual Modeling
|:||§ External Data Objects |

il Reference Objects

W] &\ Shapes

A T T T

DB

@ [ ok || concel |

L A

3. Click OK and the resulting Impact Analysis Report should resemble the following graphic.

@ Fault Resolved 2 }

@ End Event: Fault Resolved

7
&
{
S
General Filter On >
Description T
Notes 4 Woaorkspace Hierarchy ,'P
- 4 ACME Company 5
Triggers 4 @- Compliance Reinstaterent Project
Assignments iy Shipping Process Model
Links 4 *ﬁ“ Diagram Usage ‘::3
W Order Picking
Impact Analvsis 4 (@ Heritage
mpact Analysis a [} Parent
D‘E Order Picking Peol ,_/L
4 JJ Children
@ Fault Resolved.Message Trigger ::}
i
%
A1 [FE A =| 2
Ell N
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Session 4: Creating a Conceptual Model Diagram

In this session we are going to create a conceptual model and diagram. Then in the next
session we will export that model to ER/Studio. We will also create and bind a Business
Element and a Domain to Business Attributes.

We are going to create a conceptual model and diagram within the workspace we created
earlier.

1.
2.
3.

6.

30

Right-click the workspace node labeled “Acme Company” and select New > Model.
Enter the Model name “Sales.”
In the Model Type drop-down list, select Conceptual.

We are going to place this model under the Compliance Reinstatement Project node, so
select it.

Next, click the Create a diagram within this model option and enter the name “Sales
Components.”

[ MNew Model - - Iﬁ )

Create a Model

Enter the details for the model and create a diagram, if desired.

Model name:

Sales

Model type: | Conceptual - Validate against BPMMN 1.x

Description:

Select where to create the model:
Fi ACME Company
Pl @- Compliance Reinstaternent Project
ﬁ Shipping Process Model
@- Compliance Reinstaternent Project Part Two

Diagram cpticns
Create a diagram within this model

Diagram name: Sales Components

|i?;- [ OK ] [ Cancel ]

L8 A

Click OK and the diagram Sales Components is placed in the Sales model. The Conceptual
Objects palette now appears in place of the Business Process Objects palette.




10.
1.

12.

13.

Expand the Conceptual Objects palette, select a Subject Area (%) and click in the Diagram
View.

Name the Subject Area “Sales.” Once you have named it, enlarge the element so it is
approximately three times its original size.

A subject area can reference a collection of entities. You can embed the entities in the
subject area, or you can have the Subject Area reference a diagram that contains entities.
For this example, we are going to embed two entities in the subject area.

Select Business Entity (@) from the palette, and place two of them inside the Subject Area.
Name the first one “Order” and the second one “Product.” When you place the entities in
the subject area they are automatically mapped to that subject area.

Double-click on the Sales Subject Area to open the Property View.
Click the Mappings tab. This hierarchy shows that both entities map to Sales.

@ Sales 3

@ Subject Area: Sales

N
{
p
General j{
Description + B Mappings ‘3
Notes 4 B Compliance Reinstatement Project f
Mappings 4 ﬁ Sales f_}
Links () Order =
1
Usage (CRUD) @ Product Z
Impact Analysis J
1
Appearance 1
R
-
-
o
£
—

Select the Business Attribute element (H) and place three (3) of them in the Order entity.
Name the three attributes as follows: “Ship to Address,” “Bill to Address,” and “Order
Status.”

Place three Business Attributes in the Product Entity. Name them “Product Name,”
“Category,” and "“Description.”

Order Product
# Ship to Address Product Name

Bill to Address Category
Order Status Description
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When building conceptual models, you need a way to mark attributes in an entity as a
primary identifier, which is similar to a primary key identifier in a physical model. ER/Studio
Business Architect uses the CASE notation, which is a “#" symbol placed before the

attribute name.

14. To set a unique identifier on an attribute, right click the attribute, “Ship to Address” and
select Unique ldentifier from the shortcut menu. The attribute is now shown with the

unique identifier symbol (#).

\? Format Tools Window Help

e o N T = L O -
@@amM./Cc i

- - -

Product

L # Ship To Address Product Name
ety Cateqgory
Order Status Description

Project Part Two

1 [ 1

@ Sales | O Ship To Address &2 | O Bill To Address| O Product Name| O Categery| O Description

O Business Attribute: Ship To Address

AN NN N N AL

General
Description
= 8 Notes i
Bindings .
Width: 0
Links
Usage (CRUD) | ><°'® ¢
Impact Analysis | Optionality: Mandatory =
Appearance Business element binding options Domain binding options
Bound business element: None - Bound domain: | None  ~

@@ 0 — -

T A N N T N N I e A VA

T oA TN

1

Click the drop-down arrow next to the Relationship icon (") on the palette. You can select

one of four relationship types: Relationship, Many to Many, Many to One, and One to Many.
For this example, we are going to set the relationship type as “One to Many.” Create a

relationship between the Order and Product business entities.
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16. We are now going to set the source/target optionality setting. Double-click the Relationship
to open the Property View. In the Optionality drop-down list box select “Mandatory to
Optional.” Notice that the "“split-line” notation shows the optionality setting in the diagram.

Order Product
# ship to Address Produck Mame
Bil to Address e -|------- —a  Category
Order Status Description

17. Right-click the relationship and select Show > Name. The relationship is now labeled
“Order.Product.”

18. Right-click in the Sales subject area and deselect the “Show as Expanded” command. The
subject area is collapsed and shows only the name of the subject and hides its contents.
You can use the subject area as a single object, or expanded to show its contents.

19. You can also change the shape of the subject area from an oval to a rectangle. In the
Property View for the Sales subject area click the Appearance tab. In the Shape options,
select Rectangle and the shape is changed.

Sales

20. For purposes of this session, reset the rectangle setting to oval, and check the “Show as
Expanded” option.

41



Creating mappings

A Mapping defines the transformation/association/semantic link between model layers. For
example: Subject Area -> Conceptual Model -> Logical Data Model -> Physical Data Model. In
an Entity/Relationship data model, we would say that a logical entity is “mapped” to a physical
table when a Logical Model is forward engineered to create a physical model. Similarly, a
Subject Area can be mapped to one or many Business Entities or Conceptual diagrams.

An example of how objects are mapped from the Conceptual to Physical layers is shown in the
following graphic:

Subject Area
Iz Mapped To

Business Entity

ﬂ Iz Mapped To
Logical Entity

Logical 4w

. .-'>§E ﬂ ls Mapped To
Physical L= Physical Table
-
ﬂ Iz Mapped To
n] m Implementation I Implemented Table / DDL
pez Sybase Cracle

You can map a Subject Area to one or more Conceptual Model diagrams. In this portion of the
session, we are going to create another Conceptual diagram and map the Sales Subject Area in
our first diagram to the newly created diagram.

1. Inthe Model View, right-click the model node labeled “Sales” and select New > Diagram.

2. Name the new diagram “Sales Components Part Two,” leave the default location of
“Sales,” and then click OK.

Place two entities in this diagram and name them “Processing” and “Shipping.”

4. Inthe Diagram View area, click the diagram tab labeled ”Sales Components” and right-
click in the "Sales” Subject Area.

5. Select Edit Mapping and the Edit Mappings dialog opens. This dialog shows that two of
the entities are already mapped (Order and Product). This mapping happened
automatically when the “Order” and “Product” entities were placed in the “Sales” Subject
Area.

6. Select “Sales Components Part Two “diagram and the two entities “Processing” and
“Shipping,” and then click OK.
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Edit Mapping

™)

Edit Mapping for Sales (Subject Area)

Select the elements to add as targets for the mapping, or clear the targets to remove from the mapping.

P ACME Company
F] @- Compliance Reinstatement Project
4 ﬁ Sales
[C1[5] sales Components
Sales Components Part Two
[[1[E] Business Entity2
(] (M) Order
[#][E] Processing
] (M) Product
[¥]([E) shipping
4 Dﬁ Shipping Process Model
[C1[€] Order Picking

D@- Compliance Reinstatement Project Part Two

1?'\

H

ok || conce |

e

o

7. You can view the results of your diagram mapping several ways: via the shortcut menu of
the Subject Area or via the shortcut menu in the diagram. In the Property View of the
subject area, you can view the mappings on the Mappings tab or the Impact Analysis tab.

@ Sales i3

General
Description
MNotes
Mappings

Links

Usage (CRUD)
Impact Analysis

Appearance

@ Subject Area: Sales

Filter OFf

> Workspace Hierarchy
s "f} Diagram Usage
> J§ Heritage
4 [} Mappings
4 @- Compliance Reinstatement Project
4 ﬁ' Sales
(2 Order
(2 Processing
(2] Product
(2 Shipping
Sales Components Part Two

A AR WAV A A W VeV A

. Right-click in the Sales Subject Area in the first diagram and select Mappings. The
pull-right displays the diagram you just mapped as well as the model of that diagram
(Sales Components Part Two [Model:Sales)).

. Double-click the Sales Subject Area to open the Property View and click the
Mappings tab.

. In the Property View, click the Impact Analysis tab to view the mappings. You can view
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the Impact Analysis either in a tree format or a table format. We will view the table
format by clicking & located at the top of the panel.

@ Sales iE

M ~=0
@ Subject Area: Sales
-
el Filter off (&)
Description
Motes Impact Topic Element Type Name Target Element Type Target Element Name
Mappings Workspace Hierarchy Workspace ACME Company
Linke Workspace Hierarchy Project Compliance Reinstate..,
Workspace Hierarchy Maodel Sales
Us2c (CRUD) Diagram Usage Diagram Sales Components
Impact Analysis Parent Heritage Model Sales
Appearance Mappings Project Compliance Reinstate..,
Mappings Model Sales =
Mappings Business Entity Order
Mappings Business Entity Processing
Mappings Business Entity Product
Mappings Business Entity Shipping
Mappings Conceptual Diagram Sales Components Par..,

Creating and binding business elements

Business Elements are often used by business users to document their list of “terms and/or
definitions”. While from a business user’s point-of-view, this may be no more than a list of
terms, they can be used by a modeler to seed attributes of semantically-rich models. A
Business Element can be bound to different business attributes across conceptual models to
enforce naming and definition standards. In this section we are going to create a Business
Element and bind it to an existing Business Attribute in our Conceptual Model.

1. Under the Reference Objects node, right-click on Business Elements and select New
Business Element.

2. While the Business Element you just created is still in edit mode, name this Business
Element “Shipping Address.”

3.  Double-click this element to open its Property View. On the General tab, we will leave all
the properties as is. Notice under the Enforcement options that the Name, Description,

Notes, and Domain/data type properties are selected and will override the properties of
the Business Attribute it is bound to.

@ Shipping Address 2

@ Business Element: Shipping Address

Domain/data type

-
LN
%
L
General WELG RS hipping Address) }
Description H
Domain: | Mone - /
Motes
Bindings Data type: | Mone - ?
l
Links
U Enforcement eptions ﬁ,}
sage (CRUD) 3
Impact Analysis Enforce these properties when binding to business attributes: ‘{:?
Mame
Description
Motes
i

4.  Click the Description tab and enter the following description: “The shipping address
contains the Customer Name.”
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7.

8.

Highlight the text “Customer Name,” click A and select red from the Color dialog, and
click OK. The selected text is now red in the description field.

In the Diagram View, double-click the Business Attribute “Ship to Address” to open the
Property View. In the Business Element Bindings Option group box, click the drop-down
arrow in the Bound Business Element text box and select “Shipping Address.”

5] Shipping Address i3 OShippingAddress =

O Business Attribute: Shipping Address

General Name: | Shipping Address -
Description Unique identifier:
MNotes Data type: None -
Bindings ]
Width: 0
Links
Usage (CRUD) | € 0
Impact Analysis | Optionality: Mandatory =~
Business element binding options Domain binding options £
Bound business element: Shipping Address - Bound domain: | None -
Bound business element domain:
Data typ
Override the following properties of the business element: atatype
Width and scale
I Name Optionality
[T Description
[T Motes

[T Domain/data type

Two things happen with the binding of the Business Attribute to the Business Element:
. The Business Attribute is now named Shipping Address.

e The description you entered in the Business Element is now the description for the

Business Attribute and appears under the Description tab in the attribute’s Shipping
Address property view.

You can view the binding action in two places.

e  Click Bindings in the Business Attribute to show the elements the attribute is bound

to.
1] Shipping Address &3 a Shipping Address r';";

O Business Attribute: Shipping Address /:'
General MName: Shipping Address  Data type: Mone Width: 0 S{}
Description Description: The shipping address contains the <FONT CC;LC;FT:r?fB
Motes f;

. dg= Bindings
Bindings “

: "3 4 [} Reference Objects 3
Links 4 Business Elements g
Usage (CRUD) 0 Shipping Address ;
Impact Analysis v?

N T

J Click Bindings in the Business Element Property View to show the attributes bound to
an element.
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g Shipping Address OShipping Address 2

5;‘?
@ Business Element: Shipping Address $
>

General Name: Shipping Address  Data type: MNone

Description Description: The shipping address contains the «FONT C =I;L='('\’rL

Motes >

Bindings 4 == Bindings . . .

- 4 @- Compliance Reinstatement Project

- 4 ﬁ' Sales 3

Usage (CRUD) 4 [@) Order 4

Impact Analysis O Shipping Address f>
4

Mwqu\/\\fﬁr
Creating and binding domains

Domains appear under the Reference Objects node in the Model View. Domains are similar to
ER/Studio domains, which are simple attribute templates. Unlike other reference objects,
domains appear only in the Model View and cannot be visualized on diagrams. So an icon does
not appear in the palette or the toolbar.

Domain properties closely follow ER/Studio and their properties include data type, width
(where applicable), scale (where applicable), and optionality. Each of these properties can be
enforced on any attribute created based on the domain.

1. Under the Reference Objects node, right-click on Domains, and then select New Domain.

2. While the Domain you just created is still in edit mode, name this Business Element “"Date
of Order.”

3. Dragthe Domain "Date or Order” to the Order Business Entity in the diagram, and a
Business Attribute is created. When this occurs, the Domain is bound to the Business
Attribute.

4.  Double-click the “Date of Order” attribute in the Order Business Entity to open the
Property View. On the General tab you can see the bound Domain in the Domain bindings
option group box. Also note that when a Domain is bound, the Business Attribute
properties (Data Type, Width, Scale, and Optionality) are grayed out.

[[l] Date of Order | O Date of Order e
0 Business Attribute: Date of Order /’1
General \NEERRDate of Orde ’;
Description Unique identifier: [7] ‘}\
Notes Data type: MNone ()
Bindi
L_'"k'"gs Width: 0 ¢

mnks
Scale: 0 w
Usage (CRUD) 1)
Impact Analysis | Optionality: Mone - V
#
Appearance Business element binding options Domain binding options 2
Bound business element: None -~ Bound domain: | Date of Order ~ ‘}
Override the following properties of the domain: }
[ Data type \\
[] Width and scale s
Mame [] Optionality <
Description LY
Notes ;‘?
&
Domain/data type -‘\;‘
4
N
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Session 5: Exporting Conceptual Diagrams to ER/Studio
Data Architect

When we export the Conceptual model to a Logical Data model in ER/Studio Data Architect,
the Subject Area we created will be an ER/Studio submodel, and Business Entities will be
created as Logical Entities within that submodel. Also, when you have mapped a diagram to a
Subject Area, the entities of the mapped diagrams are then exported as elements of the
ER/Studio Data Architect submodel.

1.

In the Model View, right-click the model “Sales,” select Export > Model to ER/Studio
Data Architect... and the Export to ER/Studio Data Architect dialog opens. The name of
the ER/Studio Data Architect export file is by default the model name with a file extension
of .dm1. The directory where the exported file will be placed is the default workspace
directory. For this example, we will leave these settings the same.

Export to ER/Studio Data Architect I._lﬂ‘éj

Export Model "Sales’ to ER/5tudio Data Architect
Specify details about the ER/Studio Data Architect file and the elements to be included in the export.

ER/Studio Data Architect file details

Name:
Directory:  ChUsersinpollard\Documents\ERStudicBusinessirchitect

Element details
Available elements: Selected elements:
4 ﬁ Sales 4 Logical
) Business Entity2 @ (£ Main Model
[ Order
[ Processing
[ Product
[ shipping
- Sales
@@ Subject Areal

[C] Open generated rmodel in ER/Studio Data Architect when export is complete

Fren ("

L &

Click M. The Subject Area “Sales” and all four Business Entities are placed in the Selected
elements list box and appear under the Logical node.

Select the option to open the generated model in ER/Studio when the export is complete.

NOTE: This assumes you have ER/Studio Data Architect 7.0 or above installed on your
computer.

Click OK, and ER/Studio Data Architect opens with the model you exported from
ER/Studio Business Architect.

NOTE: The Shipping element may not be visible in the Diagram View because it was placed to
the right off the screen. You can rearrange the elements in the Diagram View area.
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ERfStudio Data Architect - [Sales.dm1 - Logical Model View ]

EB)X]

:'{?' File Edit View [nsert Model Format Layout Tools Repository Maoo Shortcuts Window Help _BX
HnEs & % QN PRy g 100% QA &
:I'@‘@L-q-"}--.- =% - a4 .:'_Jﬁi"aﬁfﬁ.tl 4_‘!: l
LEQQQGQ._‘: = | ng @%Eﬂ’i}, @ % &5 | .l
AL e R 2 ¢ aNAN- X
4 7 sales.dml - Logical Model View * ] box
E Sales. den) /
Logical Product
—ﬁ Main Model Order
Eniities [4] # Ship to Address
; ﬁ Dircer - - —0ez] ¥ Product Name
Fiocessing ¥ Bill fo Address w Category
IH Piaduct “w Order Status < Description
4+ Shipping % Ship o Address (FI)
F-p Attibutes [7)
EHER Kews (1)
,}j PE1.Order
Wiews . _
L—;%Flalalmghps i Processing Shipping
+= Ordes-Product
- Users
Rales
3 Shapes
gy Sales w
Boata [@outs, #0ate, Ko (Qren. | [< >
For Help, press F1 Lagical Model Views=0 | Ertiies =4  Athibutes = 7 Relationshipe = 1 MUIM

Session 6: Importing an ER/Studio Data Architect model to

a Conceptual Model

In this session we will cover how easy it is to import an ER/Studio Data Architect (ER/Studio DA)

Model into an ER/Studio Business Architect Conceptual Model. Also, once that model has

been imported, we will walk through the steps of updating it from a
Architect model.

Importing an ER/Studio Data Architect Model

n updated ER/Studio Data

1. In the Model View, right-click the Conceptual Model “Sales” and select Import > From
ER/Studio Data Architect > Create New Conceptual Objects....

2. The import type of ER/Studio Data Architect diagram is selected by default. In the Location
dialog, browse to the location of your ER/Studio Business Architect installation and go to
the following directory:
.\Program Files\ERStudio Business Architect X.X.X\samples\ERStudio
Data Architect Models
Select the file named “Northwind.dm1,” and then click Open.

3. Leave the model name as “Northwind”. Also, leave the default setting of “Sales” for the

location of the model to be created, and then click Next.
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In the Object Selection dialog, you can specify the objects you want included in the model.
From the list of Available Entities, select the Entity labeled “Customers,” and then click b
When you select a main model/submodel, all the entities inside that submodel are moved
to the Selected Entities tree. A subject area and diagram are created for each submodel. In
this case a Subject Area and diagram are created with the name “Customers.”

-
Import Conceptual Objects I. (=] g

Object Selection
Specify the chjects to include in the conceptual medel,

Entities Dﬂmainsl

Foailable entities: Selected entities:
4 = Logical a ﬁ' Morthwind
& [y Main Model @ [» Customers
& [y Orders [» @@ Customers
& &g Products & [B] CustomerCustomerDemo
& g Suppliers & [B) CustomerDemographics
b [y Territories & [E] Customers

b g Views E

Help Next » Finish | [ Cancel
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5. You can also select an individual attribute to be imported. Expand the “Territories”
submodel and in "EmployeeTerritories” entity select the attribute “EmployerlD”. Click #

and in the Selected entities tree a diagram and Subject Area are created named

“Territories.” The Business Entity “Employee Territories” and the one selected attribute

appear in the Selected Entities list box.

Import Conceptual Objects

S

Object Selection

Entities | Domains

Specify the objects to include in the conceptual model.

Lyailable entities:

Selected entities:

4 [ Logical 4 ﬁ' Meorthwind
- @y Main Model @ » Customers
- &g Orders a Territories
« &g Products 4 EmployeeTerritories
- @y Suppliers Bp EmployeelD

4 & Territories
F ﬁ EmployeeTerritories E
<> TerritoryID
» ﬂ Region
» ﬂ Shippers

s | - -
s ] Territories

- g Views

- @ Customers
& Territories
» [B) CustomerCustomerDemo
» [ CustomerDemographics
» [B) Customers
a [H] EmployeeTerritories
O EmployeelD

Help Next > Finish | [ Cancel

6. After you have made your selections on the Entities tab, click the Domains tab where all
domains in the ER/Studio model are listed.

You have the option that if you only want to see only bound domains to selected entities,
you can select that option located below the Available domains list box. In ER/Studio you
can bind a domain to an entity attribute, so this option filters out domains that are not
bound to entities.

7. Click the drop-down arrow in the Import Domains As list box. Your import options are:
Business Elements, Domains, and Business Elements Referencing Domains. For purposes
of this exercise, select "Business Elements”.

8. Select the Domain “Address” and click P. It now appears in the Selected Domains list box
as a Business Element.
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9. Click Finish and once you get the message that the import was successful click OK. The
imported model with all its associated diagrams, subject areas, and entities are placed in
the Model View tree under the model node “Northwind”. The domain you imported
appears as a Business Element under the Reference Objects node.

EE(E M &= o

Model (Fittered) 52| o |
4 ﬁ Sale

i Morthwind
» Customers
» Territories
- [ CustomerCustomerDerno
» [@) CustemerDemographics

» [B) Customers

» [ EmployeeTerritories
@@ Customers
@@ Territories

o Sales Components Part Two
(2] Business Entity2

» [ Order
[E) Processing

> [@) Product
(=) shipping
@@ Sales
@@ Subject Areal

s ﬁ Shipping Process Madel
@- Compliance Reinstaternent Project Part Two
4 [ Reference Objects

? External Data Objects
' g (w

m

fa 3 Business Elements

[ .

10. In the Model View, double-click the diagram labeled “Customers” to view it in the Diagram
Area.

Customers
# CustomerlD
+ CompanyMame
- ContactMame
- CortactTitle

- Address

= City

- Region

- PostalCode

= Country

= Phone

= Fax

CustomerDemographics
#Customer TypelD
- CustomerDesc

| !
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Updating a Conceptual Model from ER/Studio Data Architect

If you are working on an ER/Studio Data Architect model, you can frequently update your
associated ER/Studio Business Architect conceptual model, if that ER/Studio Business Architect
model was initially created by importing the ER/Studio Data Architect model. The ER/Studio
Data Architect model changes can include entity name changes, adding and removing new
attributes, adding and removing relationships, binding and unbinding existing domains, etc.

Because updates are based on an object’s unique identity rather than its name, you have ability
to re-import just the changes, or the entire ER/Studio DA model, and the existing ER/Studio
Business Architect Conceptual Model is updated. All existing relationships are maintained, and
renamed elements are updated properly. It is important to note that only the elements that
were originally created by importing the ER/Studio Data Architect model are updated. Any
elements that are created in EA/Studio Business Architect are not updated with information
imported from the ER/Studio Data Architect model.
NOTE: Since we have not updated the ER/Studio Data Architect model, we will just walk through the
steps of updating the Conceptual model.

1. Right-click the model “Northwind” in the Model View tree, and then select Import > From
ER/Studio DA> Update Existing Conceptual Objects....

2. Inthe Location dialog, browse once again to ..ERStudio Business Architect
X.X.xX\samples\ERStudio Data Architect Models\ and select the diagram named
“Northwind.dm1.”

3. Inthe workspace tree, select the model “Sales.”

NOTE:  You can select the “Delete objects in model that aren’t contained in source file.” If you
enable this option, any objects in the target model that do not match an object that you
select in the source model for update is deleted. If this option is not selected, (it is not
selected by default), none of the objects in the target model are deleted.

4. Click Next and the Object Selection dialog opens. From the list of available entities, select
the object “Customers” and click P

-
Update Conceptual Objects l =l ﬁ]
Object Selection
Specify the ohjects to include in the conceptual model,
Entities | Domains
Ayailable entities: Selected entities:
4 = Logical a ﬁ Sales
> @ Main Model @ s Customers
. @3 Orders - @@ Customers
> &g Products > (@) CustomerCustomerDemo
- @3 Suppliers . [0 CustomerDemographics
. [ Territories . [ Custorners
> @ Views E
Help Mets [ Fnish ][ Cancel

5. Under the Domains tab, select “Address” and click ¥
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Update Conceptual Objects Llﬂlﬂ—hj

Object Selection

Specify the objects to include in the cenceptual model,

Dormains

Impert demains as: [Eusiness Elements V]

Available domains: Selected domains:
i Avias
[I]] Amount I @
[I]] Area Code

i lob

Wl city 4
[I]] Country

[I]] Create Uszer @
|]I| Date

[I]] Description
Il EMail Address

»

0 Address

m

[I]] Extension

i o

=

W Te Makanle v

[] Only show domains bound to selected entities

Help Mec> [ Fnish || Cancel |

%

6. Click Finish and you will get a dialog telling you that the import was successful. Click
Details to view what items were updated. The updated information in placed in the Model
View under the “Sales” node.

Session 7: Creating a diagram from selected elements

You can create a new diagram from selected elements in the model view tree. From the model
view, you can multi-select the elements you want to create on the diagram, right click, and then
select the “Create Diagram from Selected Elements...” menu option.

Any combination of Reference Objects or External Data Objects can be selected and added in
combination with Business Process or Conceptual Model elements, with the following
exceptions: (1) Business Process triggers; (2) External Data Object attributes, columns, and data
elements; and (3) Reference Object Domains. The Create Diagram from Selected Elements
command is disabled when an invalid combination of elements is selected.

In the following example, we are going to create a diagram that includes two Business Entities
and a Subject Area that were imported from ER/Studio.
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1. In the Model View, Ctrl+click the business entities “CustomerCustomerDemo,”
"CustomerDemographics,” and the subject area “Customers.”

[ *Model (Filtered) 32 | o« | [E
4 ACME Company
4 @- Compliance Reinstatement Project
4 ﬁ Sales
- & Morthwind
> Customer Information
[ Customers
. 7| sales Compaonents

(B CustornerCustomerDemo
- (@) CustomerDemographics
- [ Customners
- Customers

. Order Picking
» 1 Order Picking Pool
E- Compliance Reinstaternent Project Part Two
4 [ff}j Reference Objects
? External Data Objects
Ed Applications
4 &) Business Elements
@ Address
@ Shipping Address
4 gl] Dornains
[} Date of Order
% Stewards

2. Right-click Customers, and then select Create Diagram from Selected Elements.... The
New Diagram dialog opens.

3. Name the Diagram “Customer Information” and select the model “Sales.” Click OK. A new
diagram is created named "“Customer Information” and placed in the Sales node in the

Model View.

i . - . J
ER/Studio Business Architect - ACME Company.exw -

File Edit View Repository Diagram Format Tools Window Help >
B - & 100% ~ @& & - - - - - - - - - = = = = {}
E@a Cllll—ll—lOﬂ""UUn./l:“u 5
= al - - §/

5 Model (Filtered) &2 | =8 Customer Information 22 5
4 ACME Company 4?
4 @ Compliance Reinstatement Project }

4 ﬁ, Sales CustomerCustomerDemo Y

. # CustomerID f“
’ ﬁ Northwind # CustomerTypelD Ty
>

> Customer Information
Customers
Sales Components
Sales Components Part Two
> [@ CustomerCustomerDemo
. [@ CustomerDemographics
» [ Customers
@ Customers
4 ﬁ Shipping Process Model
> Order Picking
> [ Order Picking Pool
@ Compliance Reinstatement Project Part Two
a I} Reference Objects
? External Data Objects
Ed Applications
4 &) Business Elements
@ Address
@ Shipping Address

Y N N NNV YN VIR o

CustomerDemographics
# CustomerTypelD
- CustomerDesc

iﬁfvv\f\/\wﬂ\,f“’“v\/v\
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Session 8: Importing external data objects from ER/Studio
Data Architect

You can import or update External Data Objects from ER/Studio DA files using a wizard. This
imports entities and tables from ER/Studio DA to 'Table' and 'Entity' reference objects.

Importing external data files

1.

From the main menu, select File > Import > From ER/Studio Data Architect > External
Data Objects > Create New....

In the Source name and Location dialog, the ER/Studio diagram is selected by default.

Browse to ... Business Architect X.X.X\samples\ERStudio Data Architect
Models\, select the file named “Northwind.dm1,” and then click Open.

Rename the Data source name as "Southwind.”
Import External Data Objects I. (=] ﬂh]

Source Name and Location

Specify the source of the external data chjects and provide a name for the data
source to be created.

Import type
@ ER/Studio Data Architect diagram

Location: CProgram Files (x86)\dera\ERStudio Business Architect 2016+ \samples\ERStu

Generic metadata

Data source name: Su:uuthwinu:l|

Help < Back Next > —

Click Next.

In Model Selection specify which models you want imported into the data source. The
model selection is based on the file you selected in the previous panel. For purposes of this
example, expand the Logical node, and then select “Products.”

When you click Next, the Object Selection panel appears. The objects that appear are
based on the selections you made in the previous panel. There are three tabs containing
imported objects: Entities, Tables, and Views. We are only going to select Entities.
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Select the “Products” folder and click ». Your selection now appears in the Selected
Entities list box. Notice that the folder labeled “Products” does not appear in this list, only
the three entities: Categories, Products, and Suppliers.

Import External Data Objects l | (=] |ﬁr

Object Selection

Specify the objects to include in the data source.

Entities | Tables | Views

Aovailable entities: Selected entities:
4 = Logical 4 = Logical
= Products ﬁ Categories
ﬁ Products
ﬁ Suppliers

Help Next > Finish | [ Cancel

-

Click Finish and a dialog opens telling you that the import was successful. The imported
External Data Objects now appear as entities in the Model View under the “Southwind”
data source, under the External Data Objects node.

Updating Imported External Data Objects

You can use the Update External Data Objects wizard to update an existing External Data
Object data source that you have already imported. All existing objects that match an object
you have selected will be updated. All objects that you have selected but are not in the existing
data source will be brought in as new. In the following example, we will walk through the
update steps even though the ER/Studio model has not been changed.

1.

56

Right-click the External Data Objects data source node labeled “Southwind” in the Model
View tree, and then select Import > From ER/Studio Data Architect > Update Existing
External Data Objects....

In the Location text box, browse to ..ERStudio Business Architect
X.X.X\samples\ERStudio Data Architect Models), select the file named
“Northwind.dm1,” and then click Open.



Leave the data source name “Southwind.”

NOTE: You can select the “Delete objects in model that aren’t contained in source file.” If you
enable this option, any objects in the target model that do not match an object that you
select in the source model for update is deleted. If this option is not selected, (it is not
selected by default), none of the objects in the target model are deleted. For purposes
of this session, select this option.

Click Next.
In the Model Selection dialog, select the logical model “Territories,” and then click Next.

In the Object Selection dialog, select the “Territories” folder from the Available Objects

window, and then click . Your selection now appears in the Selected Entities list box.
Notice that the folder labeled “Territories” does not appear in this list, only the four
entities: Employee Territories, Region, Shippers, and Territories.

Update External Data Objects L@ﬁ

Object Selection

Specify the objects to include in the data source,

Entities | Tables | Views

Available entities: Selected entities:
4 = Logical 4 = Logical
[-== Territories ﬁ EmployeeTerritories
ﬁ Region
ﬁ Shippers

ﬁ Territaries

Help Nec> | [ Finish ][ Cancel

When you click Finish, a dialog opens telling you that the import was successful. Click
Details >>... for information on what was imported. You can print or save this information.

Click OK and the new/updated objects appear in the “Southwind” node in the External
Data Objects node.
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Session 9: Exporting external data objects to ER/Studio
Data Architect

You can export External Data Objects to ER/Studio DA where all entity elements map to a
logical model and all table elements map to a physical model in ER/Studio DA. Only entities
and tables are exported. The export uses pre-defined mapping. We are going to export the
“Northwind” project that we imported in Session 6.

1. Right-click the External Data Objects node labeled “Northwind” in the Model View tree and
select Export > Model to ER/Studio Data Architect.

2. Inthe Export Model “"Northwind” to ER/Studio dialog, change the Name to
“Eastwind.dm1”.

3. Leave the default directory as . . . \Documents\ERStudioBusinessArchitect.

4.  From the list of Available Elements, click PP and all elements are moved to the Selected
Elements list box.

Export to ER/Studio Data Architect [_lﬂlﬂ_h]

Export Model "Northwind® to ER/Studio Data Architect
Specify details about the ER/Studic Data Architect file and the elements to be included in the export.

ER/Studio Data Architect file details

Mame: Eastwind.dml

Directory: ChUsers\npollard\Documents\ERStudioBusinessirchitect

Element details

Awailable elements: Selected elements:
ﬁ Morthwind 4 Logical
. [£3 Main Model

- [@g Customers
- I3y Territories

[+

[7] Open generated model in ER/Studio Data Architect when export is complete

(?:} [ QK ] [ Cancel ]

% A

5. Select the option to Open generated model in ER/Studio Data Architect when export is
complete, if you have ER/Studio 7.0 or above installed on your computer.

51



6. Click OK and the export dialog closes. The exported model is then opened automatically in
ER/Studio Data Architect.

ER/Studio Data Architect - [Eastwind. dm1 - Logical Model View *] =13
i File Edit View [nsert Model Format Layout Tools Repository Macro Shorteuts  Window  Help B X
NeaLEds & 2 QNS Yphm o7 'iﬂgéhﬂ
IR eyl Ere PANEITTEFY
EEDOQQ@J -PlsﬂT éﬁ*’ﬁuﬂﬁ’ﬁl @Q} {‘.-Iaﬁl
4 7 Sales.dml - Logical Mcq_e_!_\_f_i.t“n!_")’ Eastwind.dm] - Logical Model View * | b ox
B Eastwind dml -
o eal ErnplooymeTerritories
:'Jé L & EmployealD
--1: Main Model :
Eniities (4]
*‘; CurstomeiCustomeiDemao
CurstomerD emographics
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) *T EmployeeTemtones Customer Customer Demo Custormer Demographics
f"\) th“*ﬁs (1g) ¥ CustomerType D
EHGE Keys| ==}
%= CustomarType D (F K)  CustomarDeso
PE1 EmployeeT enitories g 0 (FKy
F‘K&Eustomelﬂemog'aphcs
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»+ CustomerD emographacs-CustomerCustomesl ¥ Customar|D
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- Usgers & ConactHame
Foles P Cornact Tale
Shapes | * Address
4y Customers v Ly
FHEg Tenitosies | :mcm'
i & Country
W Phone
+ Fax
= W
@Dﬂhﬁtﬂ Data .| #¥oata .| M Macro (& Repo.l. | ¢ »
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Session 10: Using Reference Objects

When you create a new workspace, a reference object project is automatically created as well.
There are six types of reference objects used in ER/Studio Business Architect. We already
discussed creating and using Business Elements and Domains, so this section covers more
general information on Reference Objects.
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External Data Objects: External Data Objects are “generic” data artifacts that can be
used to show the relationship and impact between data and the activities of the process.
External Data Objects are not entity relationship modeling artifacts, but an abstraction of
these objects. You can import or create new external data objects and then link those
objects to business process or conceptual elements.

Business Elements: Business Elements are often used by business users to document
their list of “terms and/or definitions.” While from a business user’s point-of-view, this
may be no more than a list of terms, they can be used by a modeler to seed attributes of
semantically-rich models. A business element can be bound to different business
attributes across conceptual models to enforce naming and definition standards. An
organization can achieve a common meaning and lineage around core business
concepts such as “customer,” “customer identifier,” “trade,” etc. by using the business
element concept.

"o

Business Rules: Business Rules are policies, practices, or formulas related to the
operation and enforcement of business practices.



e Business Units: Business Units are organizational areas within or external to an
enterprise, for example, Human Resources, Sales, Accounting, etc.

¢ Domains: Domains are reusable attribute templates that promote consistent domain
definitions such as name and data type properties.

e Stewards: Stewards are people or organizations responsible or associated with model
elements, for example: DBA, Auditor, Jeffrey Smith, etc.

Creating Reference Objects

There are several ways to create reference objects: on the Model View; from the Reference
Objects palette; from the Reference Object toolbar; and importing from CSV files. When you
create a reference object from the palette, you can select the object you want to use from the
palette and then click once in the Diagram View. Once placed on the diagram, it also appears
in the Model View.

2 Palette 53 = 8

L4 Marquee

Conceptual Objects
[fff\ Reference Objects 40

% Steward

D[E Business Unit

@ Business Rule

0 Business Element
G Application

Link

U, Usage

f External Data Objects
p_\._ Drawing Shapes

The following example walks you through the creation of an object on the Model View.

1. Right-click on a reference object in the Model View and select New. The command that
appears depends on the reference object clicked. For example, right-click on Stewards, the
command will be New Steward.

The newly created reference object appears below the selected object in the Model View
in the edit mode. Name the new Steward “Order Clerk.”

TEE- o

*Model (Filtered) 22 | < | [E [
4 ACME Company
3 @ Compliance Reinstatement Project
a I} Reference Objects
4 &P External Data Objects
3 @ Southwind
EA Applications
3 E’ Business Elements
3 gl] Domains
4 & Stewards
% Order Clerk

LA T TN

When you right-click the newly created object you gain access to a shortcut menu where
you have the following options: rename, delete, create or edit a link, create or edit a usage,
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create an impact analysis diagram, view an impact analysis report, and change the
properties. You can also double-click an object to open the Property View.

2. Once you create the reference object, you can then drag that object onto the Diagram
View. A representative icon is placed in the diagram. You can then connect these objects to
other objects. The example below shows the Steward “Order Clerk” connected to a task via
an Association Link.

Gl 5] __ _Order ClerkProress Order | process Order

Order Clerk

External Data Objects

You can import or create External Data Objects. When you right-click an external data object
you gain access to a shortcut menu where you have the following options: rename, delete,
create or edit a link, create or edit a usage, create an impact analysis diagram, view an impact
analysis report, and change the properties. You can also double-click an object to open the
Property View. You can then create links to associate external data objects with any element in
a Business Process or Conceptual Model diagram.

. Palette 3 = 8

L Marquee
Conceptual Objects
[fff Reference Objects
&P Bxternal Data Objects

[ Entity

[ Table

Ef View

[T] Data Store

) Data Feed

Report

Flat File

EH_’ Drawing Shapes

Creating External Data Objects from a Palette

You can place External Data Objects on a diagram from the External Data Objects palette.

Select the desired object from the palette and click in the Diagram View area to place it. Once

placed on the diagram, it also appears in the Model View.

NOTE: See Session 8: Importing external data objects from ER/Studio Data Architect for how to
import External Data Objects from ER/Studio. Session 9: Exporting external data objects

to ER/Studio Data Architect steps through the process of exporting External Data
Objects to ER/Studio.

Session 11: Using the Grid Editor

The Grid Editor is a spreadsheet-like display format used as an alternative to the Model View.
This is valuable for displaying large numbers of objects or business-related textual objects, such



as business rules. Grid Editor content can be printed or exported as a report in CSV, HTML,
PDF, and RTF formats.

Displaying and editing information in the Grid Editor
For purposes of this evaluation guide, we are going to open the grid editor of the business
process diagram we created earlier.

e Inthe Model View, right-click the diagram node labeled Order Picking and select Grid
Editor. The grid editor opens as a tabbed view.

Order Picking — Order Picking: Grid Editor &2 = B8
Object Type Mame Description Motes

1 Events Fault Resclved

2 Intermediate Event

3 Order Filled

4 Start Event

5 Sequence Flows CheckInventory.Check Crder Pull

6 Check Order Pull.Order Filled

7 Check Order.Check Inventory

g Handle Fault.Fault Resolved

9 Intermediate Event.Handle Fault

10 Start Event.Check Order

11 Tasks Check Inventory

12 Check Order

iy
7%}

Check Order Pull
Handle Fault
Task

Taskl

[ e
SR

The grid editor lists all elements in the diagram and is categorized by object type. Each
element displays the object type, the name, a description field, and a notes field.

You can edit the name, description, and note for each record in this view by clicking once on
the text in the cell. You can copy and paste text in the Description or Notes fields from another
application such as Microsoft® Word.

Open the Property View for each record by selecting a record and pressing Alt+Enter. You can
then edit the properties, view the impact analysis hierarchy, create a link, and create a usage.

Using the Grid Editor for entering Reference Objects data

The Grid Editor provides a fast and simple means of entering large amounts of data for
Reference Objects. In this example, we will be entering data for Business Rules.

1. Right-click the Stewards subnode under the Reference Objects node in the Model View,
and then select Grid Editor.

The Grid Editor opens showing “Order Clerk” in line one.

When you select line two, the Name cell becomes editable. Enter the name “Processing
Clerk” and tab to the Type cell.

Select “Individual” from the drop-down list available, and then click in the Description cell.
Enter the text “The Processing Clerk works with the Order Clerk”.

Tab to the Notes column and enter the text “Job responsibilities for the Processing Clerk”.

N o o B

Tab one more time and a new row is automatically created where the Name cell is editable.

Note also that a Steward labeled “Processing Clerk” now appears in the Model View under
the Steward node. You can quickly navigate through the rows of data. Each time you press
enter you advance down one row. When you reach the last row, you are returned to the first
row.
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Customers
Sales Components
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[ CustomerCustomerDemo
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I Overview 2 | i)

A diagram must be open in order to use the Overview window.

|A paletteis not available.

Model View Filter: On

Customizing the Grid Editor

You can select the columns to be displayed in the opened grid editor.

1. Right-click anywhere in the Grid Editor and select Customize Columns ¥l to open the

Customize Columns dialog.

B
Select the columns to be displayed in the Grid Editor:

Mame

Type

E-mail Address
Responsibility
Description
Motes

-
'l::} Customize Columns

Cancel ]

@ Lok

L A

2. Select the columns you want to include in the view, and then click OK.
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Session 12: Exporting data

You can save generated views or reports such as the Grid Editor and then open them in
another application with a single step. We are going to export the contents of the grid editor
that we populated in the previous session to an Excel spreadsheet.

1. Inthe Diagram View, click the tab labeled “Order Picking Grid Editor” to view the grid we
generated previously.

2. From the main menu, select File > Export > Grid Editor, or click &3 on the Standard
toolbar.

3. Inthe Export dialog, select a directory where you want to store the exported file. You can
store it in the same folder where you save your workspaces. The default file name for the
exported file is the name of the Grid Editor tab (for example Order Picking Grid Editor).
Leave the default name.

4. Inthe Select As Type text box, select Comma Separated Values File (*.csv) from the drop-
down menu, and then click Save. A CSV text file is created, which can be viewed in Excel or
a text editor. If you have Excel on your machine, you can go to the file location in the
Windows Explorer and double-click the file to view it. You can also export to the following
file formats: HTML, PDF, and RTF.

( |'._7‘| = |= Order Picking Grid Editor.csv - Microsoft Excel | == [ i
m Home Insert Page Layout Formulas Data Review View Acrobat 2 9 = e &
Al - Je | Object Type ¥
A | B c D E F G i
1 |Object Type Iname Descriptic Motes ]
2 End Event Fault Resolved
3 Intermediate Event Intermediate Event
4 End Event Crder Filled
5 StartEvent Start Event
6 Seguence Flow Check Inventory.Check Order Pull
7 Seqguence Flow Check Order Pull.Order Filled
8 Sequence Flow Check Order.Check Inventory
9 Sequence Flow Handle Fault.Fault Resolved
10 Sequence Flow Intermediate Event.Handle Fault =
11 Sequence Flow Start Event.Check Order
12 |Task Check Inventory
13 Task Check Order
14 Task Check Order Pull
15 Task Handle Fault
16 Task Task
17 Task Taskl
18
13
20 B
21 3
4 4 v ¥ | Order Picking Grid Editor %2 [T il | 0|
Ready | |FEEE 0% (= J (+)
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Session 13: Importing Visio models

You can import Microsoft Visio diagrams into Business Process and Conceptual models. When
you import a Visio model, the wizard walks you through the creation of a model and associated
diagrams. A diagram is created for each page in the Visio model. A mapping table lists the
Visio objects and the corresponding ER/Studio Business Architect objects. You can also create
and save user-defined mappings.

NOTE: You must have the Visio application installed on your computer to import a model.

1. From the main menu select File > Import > Microsoft Visio Model to open the Microsoft
Visio Import Wizard.

2. Browse to the folder where your existing Visio models are stored and select the model you
want to import. For this part of the Evaluation Guide browse to ..\ERStudio Business
Architect X.X.X\samples\ Visio Models\ and select the
CreditApplicationProcess.vsd. Click Open to accept your selection and close the
Browse dialog.

NOTE:  Make sure that the diagram you are importing is closed in Visio.
Microsoft Visio Import Wizard I =X

Import a Microsoft Visio Model into ER/Studio Business Architec

Specify the location of the Visio model to be imported into ER/Studio
Business Architect and select the type of model to be created.

Location: CA\Program Files (x86)\Idera\ERStudio Business Architect 17.0\samples

Model type: (@ Business Process () Conceptual

" 4

3. Select Business Process as your model type and click Next to advance to the Model and
Diagram Details page.

4.  You can rename the model in the Model Name text box. We will leave the default name,
which is Visio's file name of “Credit Application Process.”

5. You can create the model in the opened workspace, project, or model. In the hierarchy,
click on the node Shipping Process Model.

In the Diagram Options section, a diagram is created for each page of the Visio model.



The Page name that appears is based on the page name in Visio. In this example there are

two pages: Customer Loan Application Process and Lender Loan Application Process.
You can edit the default names.

Micrasoft Visio Import Wizard { =] ﬂ

Model and Diagram Details

Specify details about the model and diagrams to be created during the
import process.

Model options

Model name: CreditApplicationProcess

Select where to create the model:

4 BF Acme Company
4 [ Compliance Reinstatement Project
i Shipping Process Model
™ Compliance Reinstatement Project Part Two

Diagram options

For each page in the Visio model, a diagram with the same name will be created. The diagram

Page Name Diagram Name
Customer Loan Application Process Customer Loan Application Process
Lender Loan Application Process Lender Loan Application Process

Help < Back " Next = l [ Finish ] [ Cancel
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7. When you click Next, the Mapping Visio Objects to ER/Studio Business Architect Objects
panel opens. The table lists the Visio object types and their corresponding ER/Studio
Business Architect object type.

Micrasoft Visio Import Wizard = =l D4

Mapping Visio Objects to ER/Studio Business Architect Objects

The following object types have been found in the selected Visio model.
The table below shows how the Visio objects will be mapped to ER/Studio

Custom mapping options
["] Use custom object mappings

Mapping file location: Browse...

(&) (=]

»

Visio Object Type and Object Nam... Page Ma.. ER/Studio Business Archite...

» CFF Container Mone

» Database Data Store

> Decision Gateway (Data-Based with... =
» Dynamic connector Nane

» Dynamic connector.12 None |
» Event Start Event

» Function Task

» Magnetic tape Data Feed

» Phase List Mone

Help Next > Finish || Cancel |
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Creating custom mappings

You can create and save user-defined mappings for Visio object types in the Mapping dialog.

1.
2.

Select the Visio Object Type Event.

Click the corresponding ER/Studio Business Architect Object Type and a drop-down list
box opens. (You can also press F2.) This list box contains all supported Modeling elements,
Reference Objects, External Data Objects, as well as the settings Default and None. Select
the item Data Feed.

NOTE: If you want to restore the original mappings, click the Restore Default Objects Mapping

con( B
Micrasoft Visio Import Wizard L@i—hj

Mapping Visio Objects to ER/Studio Business Architect Objects

The following object types have been found in the selected Visio model.

The table below shows how the Visio objects wiII

Custom mapping options Data Object
Data Store —

Drawing Shape (Annotation)
Drawing Shape (Circle) E...
Drawing Shape (Cylinder)

Drawing Shape (Diamond)
Drawing Shape (Hexagon)
Visio Object Type and Object Nam... Page Na.. |Drawing Shape (Octagon)

Drawing Shape (Pentagon)
Drawing Shape (Rectangle)

["] Use custom object mappings

[ »

» CFF Container

’ Datét_nase Drawing Shape (Round Rectangle) =
» Decision Drawing Shape (Text) N
» Dynamic connector Drawing Shape (Triangle)

» Dynamic connector.12 Embedded Sub-Process il

» Event Data Feed -

» Function Task

» Magnetic tape Data Feed

» Phase List Mone

Help Mext = Finish ] [ Cancel l
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3. To save your settings, click tﬂl to open the Save Mappings dialog. Enter the name you
want to use for the saved mappings, which will be saved as an XML file. Name the file
“Loan Process,” and then click Save.

NOTE: If you want to use the custom mappings for your next Visio import, click Use custom
object mappings on the Mapping Visio Objects to ER/Studio Business Architect
Objects panel of the wizard. The Mapping File Location and Browse options are made
available.

Microsoft Visio Import Wizard L@éj

Mapping Visio Objects to ER/Studio Business Architect Objects

The following object types have been found in the selected Visio maodel.
The table below shows how the Visio objects will be mapped to ER/Studio

Custom mapping options
Use custom object mappings

Mapping file location: | S5at{e i =la RVRNEET o] SANIETo) Mlels S ReET N M o Tal=3H ]| | | Browse...
(1]

Visio Object Type and Object Nam... Page Ma.. ER/Studio Business Archite...

» CFF Container Nane

» Database Data Store

> Decision Gateway (Data-Based with... =
» Dynamic connector None

» Dynamic connector.12 Nane |
» Event Data Feed

» Function Task

» Magnetic tape Data Feed

> Phase List Nane

Help Next = Finish J [ Cancel l

L 4

Instance-level mappings

You also have the ability to map each individual object in the Visio model. It is important to
note that these Instance-level mappings are not saved as part of the custom mapping file and
are used for this import only. You will get an “Unable to Save Instance-Level Mappings”
warning dialog when you click Save.

1. Click ¥ next to the Visio Object type “Terminator” to display the individual objects.
2. Select the Visio Object type “Unnamed” and click “End Event” to open a list box.
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3. Select "Off-Page Connector” from the list box which is now displayed in the ER/Studio
Business Architect Object type. This mapping will be used in the import process.

NOTE: You can set a preference to either retain Visio element sizes or use ER/Studio
Business Architect’s default sizes.

Microsoft Visio Import Wizard L@éj

Mapping Visio Objects to ER/Studio Business Architect Objects

The following object types have been found in the selected Visio maodel.
The table below shows how the Visio objects will be mapped to ER/Studio

Custom mapping options

Use custom object mappings
Mapping file location: 2ss Architect 17.0\samples\Visic Models\Loan Process.xml

B (d) (@]

Visio Object Type and Object Nam... Page Ma.. ER/Studio Business Archite...

» Magnetic tape Data Feed

» Phase List Mone

» Separator Nane

» Swimlane Mone

» Swimlane List Nane

4 Terminator End Event 3
| Unnamed Customer... Off-Page Connector

Help Mext = Finish ] [ Cancel l

L "

4.  Click Finish and the Importing Visio Objects message box opens. Click OK to view the
imported models in the Diagram View area. In the Model View, the imported diagrams are
listed with all associated elements listed as subnodes. Click the Customer Loan Application
tab in the Diagram View area to open the imported diagram.

Q —

Event
g .O . .II. O
Apspdica thon FLE & panirie MO 1
-
-
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Session 14: Importing comma separated value (CSV) files

You can import large amounts of data into ER/Studio Business Architect using the CSV import
wizard. You can include Business Elements, Business Entities, Business Rules, Business Units,
Stewards, Subject Areas, Domains, and Tasks. Using pre-existing templates, you can input data
into a comma separated value file and then import it into the application.

Templates exist for each object and are available in x:1Program Files\IDERA\ERStudio Business
Architect XX X\ samples\CSV\Templates. You can open these templates in Microsoft Excel or a
text editor to enter data.

1. On the main menu, select File > Import > Comma Separated Values (CSV) and the CSV
Import Wizard opens.

€SV Import Wizard [

Object Type and File Location
Select the type of object to import and the location of the Comma Separated Values (C5V) file,

Available object types

@ Business elements
Business entities
Business rules
Business units
Domains
Stewards
Subject areas
Tasks
Applications

File options

Location: Browse...

| First line in file is header

Help < Bac lext = Finish Cancel

2. Ensure “Business Elements” is selected from the list of available object types.

3. Inthe Location text box browse to ... ERStudio Business Architect
XX X\Samples\CSV\Data\Waterfront Bank\Waterfront Business Elements.csv and click
Open.

4. You can import CSV files with or without headers. If the file you are importing has headers,
keep the “First line in file is header” option selected.

NOTE: If this option is not selected and your file has headers, your first row will be imported
as data. For example, if your headers were Name, Data Type, Description, and Notes,
when the file is imported, your first row of data would be the Name, Data, Type,
Description and Notes. This may cause errors because the import values will be
invalid.
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Click Next and the Possible Duplicate Elements dialog opens informing you that the target
project contains existing elements. You have two options: create a new Business Element
with a unique name or update the existing business element. We will select the first option.

When you click Next an Import Summary dialog opens displaying all the records that have
been imported.

CSV Import Wizard =y X

Import Summary

The table below summarizes the elements which will be created in the model.

9 business elements will be imported:

Name Data Type Description Motes
@ Tax Identifier A unigue identifier used ...
@ Account Arecord of financial tra...
@ Adjustable Rai Any interest rate that ch...
@ Bank Discoun The bank charge made f...
a Tirne Draft A draft which is payable ...
Q Signature Gua An authentication of a si...
@ Account Balar Decimal The amount of money i..
@ Reserve Ratio Armount of money and L.,
a Average Daily The average amount tha...

Help Next > Finish | [ Cancel
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7. Click Finish and a CSV Import Complete notification dialog opens telling you how many
elements were created in ER/Studio Business Architect.

*Model (Filtered) 22 | & | B = M= 0
4 ACME Company
: @ Compliance Reinstatement Project
a [ff}y Reference Objects
. &7 External Data Objects
Ed Applications
4 £ Business Elements
e Account
@ Account Balance
@ Address
@ Adjustable Rate
0 Average Daily Balance
@ Bank Discount
@ Reserve Ratio
@ Shipping Address
@ Signature Guarantee
@ TaxIdentifier
@ Time Draft

: gl] Domains

» % Stewards

U o et WU R i PRI WX

8. If you are importing reference objects, once you close the notification dialog, the imported
elements are placed under the appropriate Reference Object node in the Model View. In
our example, nine imported elements were placed in the Business Elements node.

9. If you are importing Subject Areas, Tasks, and Entities, they are placed in a model. You are
prompted where to place them on the Model and Diagram Selection panel of the Import
Wizard. You can also select the option to create the imported element on either a new or
existing diagram.

Session 15: Creating links and Impact Analysis diagrams

When you create a link, you create a generic relationship between elements that can indicate
impact, association, etc. A Link is a generic, user-defined relationship that is used to simply
relate objects together. However, a link is not associated with a formal modeling notation; thus
you are free to use it to connect any objects within ER/Studio Business Architect.

A common usage would be to show and relate stewardship with a given task or table. Once
you have created these links, you can view an Impact Analysis report showing the
interrelationships.

Creating a link

We are going to link a table we imported from the ER/Studio sample model to the “Check
Order” task we created in our Business Process diagram.

1. Click the Order Picking tab in the Diagram View to display the diagram you created. (If this
diagram is no longer open, double-click the Order Picking node of the Shipping Process
Model in the Model View.)

2. Right-click the task labeled Check Order, select Links > New, and then the Create Link
wizard opens.

3. Inthe Target elements list box expand the Entities subnode in the External Data Objects
node and select Suppliers.
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4. We will specify the following details for a new link in the Create Link dialog:

Name: Name the link Check Order Supplier Link.

Verb Phrase: Type a verb phrase that describes the relationship from the perspective of
the target. Enter the text SUPPLIER validates ORDER.

Inverse Verb Phrase: Type an inverse phrase that describes the relationship from the
perspective of the element to be linked to. Enter the text ORDER is validated by
CUSTOMER.

Description: Enter any descriptive text you want here.
Notes: Enter any descriptive text you want here.

Create Link | (5] e S

Create Link for Check Order (Task)
Specify the details for the new link.

Target elements Link properties
% D Ty Triggers - MName:
4 Dﬁ' Conceptual Modeling Check Order Supplier Link

. [[] O Business Attributes
- [[]1[F) Business Entities

- [ Subject Areas

s [ e Relationships N Inverse verb phrase:

4 [M] &P External Data Objects ORDER is validated by CUSTOMER
- [T Attributes
4 [H|[ Entities
[C1&3 Categories T
[C1& Products
ﬁ Suppliers
F] |:| Projects/Models/Data Sources
[ & Morthwind e
[ ﬁ Sales A Motes:
[C] 1 Shipping Process Model i
[C][% Southwind
D[’E& Compliance Reinstatement Project -

i

Verb phrase:
SUPPLIER validates ORDER

Description:

m

@ [ 0K ] [ Cancel

5. Click OK and the Create Wizard dialog closes.
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6. Right-click in the diagram and select Connections > Show > Links. The link you just
created is then displayed in the Order Picking diagram.

@ Check Order Check Inventory Check Order Pull
Start Event Order Filled

Handle Fault

Fault Resolved

Suppliers

Impact Analysis diagram

An Impact Analysis Diagram is a way to visually represent the linkages that have been created
between objects. These diagrams are automatically generated based on the link-related
metadata.

1. To create an Impact Analysis Diagram right-click the Suppliers node in the External Data
Objects node in the Model View.

2. Select Impact Analysis > Generate New Diagram. A diagram is created as a tabbed view
in the Diagram View area and is named “Impact Analysis for Suppliers”.

3. Todisplay the all the information on the link, right-click the link and select Show. A list of all
available labels is available on the pull-right menu.

Check Order

Show 4 Mame
Appearance... Verb Phrase
Connections 3 Inverse Verb Phrase
Grouping »

Edit 3

Layout 3

Create Diagram from Selected Elements...
Find in Model View
£L] Properties

Suppliers
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The following graphic shows a diagram where all available labels were selected.

Check Order ]-——— Originating Element

SUPPLIER validates ORDER <= \ferb Phrase

Check Order Supplier Link s Link Mame

i 4+—— Target element

Suppliers

The created Impact Analysis diagram also appears in the Model View.

Model (Filtered) 23 | o |

4 ACME Cormpany
: @- Compliance Reinstatermnent Project
4 [f}y Reference Objects
4 ? External Data Objects
4 |9 Southwind
; Impact Analysis for Suppliers
> ﬁ Categories
> ﬁ Products
> ﬁ Suppliers
Ed Applications
» g Business Elernents

b E;I] Domains

. % Stewards

You can view your Impact Analysis Diagram in a grid view.

1.

DRDER is validated by cusTOMER+— [nverse Verb Phrase

Right-click in the background of an opened Impact Analysis Diagram or right-click on the
Impact Analysis Diagram in the Model View.
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2. Select Grid Editor. The information now appears in a grid format with full editing

capabilities.

Impact Analysis for Suppliers — Impact Analysis for ...: Grid Editor 23 7
Object Type Mame Description Motes 3
1 Entities Suppliers /
2 Links Check Crder Supplier Link g

Tasks Check Order 4
>

-~

MM%WMWM

Update an Impact Analysis diagram

Instead of generating a new Impact Analysis diagram each time you add links or usages, you
can refresh or update your existing diagram to show new connections.

1. Inthe Diagram View area, click the “Impact Analysis for Suppliers” tab to open the
diagram.

2. Right-click in the background of an existing Impact Analysis Diagram in the Diagram View
and click Update Impact Analysis. You can also right-click the Impact Analysis diagram
node in the Model View and click Update Impact Analysis.

3. The diagram is updated with any changes you have made.

NOTE: This menu option is available only if the Impact Analysis diagram is open and is
selected on the Model View

Session 16: Creating usage relationships

When you create a usage, you create a generic relationship between elements that can show
the relationships between data and process for Usage (CRUD) Reporting.

A Usage denotes a usage association, with attributes to represent whether the usage is
Created, Read, Updated, and/or Deleted. Once you have created these usages, you can view
the Usage (CRUD) reports showing the interrelationships.

Creating a usage

We are going to show a usage between tasks and external data objects in a Business Process
diagram.

1. Double-click the diagram “Order Picking” under the Shipping Process Model node to
open the diagram.

2. From the External Data Objects palette click the Data Store object (r:l) and place in above
the Check Inventory task on the diagram and label it “Inventory Database”.

3. From the same palette click the Report object (E) and place it above the Check Order task
on the diagram and label it “Existing Orders”.

4.  For our last object, click the Table object () and place it above the Check Order Pull task
on the diagram and label it “Orders Pulled”.

5. Right-click on the task “Check Inventory” and select Usage (CRUD) > New to open the
Create Usage wizard.

9.0 In the Target elements list box expand the Data Stores node under the External Data



Objects node, and select “Inventory Database”.

7. For now, we will leave the Usage properties as selected and will edit them later. Click OK to
close the wizard.

Create Usage l ] |-

Create Usage for Check Inventory (Task)

Specify the details for the new usage.

Target elements Usage properties

4 Dﬁ Conceptual Modeling g Create [V]Read Update Delete
- [[] O Business Attributes
> [[][2) Business Entities
» [C]@® Subject Areas n
» [] »+ Relationships

4 [ &P Edternal Data Objects | _
s Dﬁ Attributes
4 [T] Data Stores

[¥[T] Inventory Database
s Dﬁ Entities
2 [ 5] Reports
> [T Tables Naotes:
4 |:| Projects/Models/Data Sources
[C] & Northwind
[ & Sales 1
[7] % Shipping Process Model
[][%¥ Southwind
D@- Compliance Reinstatement Project -

Description:

m
1

® [ oK l ’ Cancel

“ v

8. Repeat this procedure to create usages between both the:

. “Check Order” task and the data feed "Existing Orders” and
. “Confirm Order Pull” task and the table “Orders Pulled”

9. Right-click in the diagram and select Connections > Show > Usages. The Usages you just
created are then displayed. Notice that the usages are automatically labeled.

D i

Exiting [Orders Inventory|Database Orderg Pulled
C, R U,D C,RUD C,R,UD

Check Order Check Inventory Check Order Pull

Start Event Order Filled
Handle Fault
Fault Resolved

I —
Suppliers

10. In the diagram, double-click the Task labeled “Check Inventory” to open the Property
View. Select the Usage (CRUD) tab to view the Usage information.
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1.

72

NOTE: By using the buttons located at the bottom of this panel, you can add, edit, or delete
usages. You can also print, export, and show selected usages in the diagram.

General
Description
Motes
Activity
Properties
[0Rules
Input Sets
Output Sets
Assignments
Links
Usage (CRUD)
Impact Analysis

Appearance

[ Check Inventory &2

™ Task: Check Inventory

Filter Off
Recervers Usage Usage Description
Data Stores

Inventory Database CRUD

+] SEEE

N oyt -
NN W”“"\f NN

We need to edit the Usage settings for each Receiver. Select “Inventory Database”
click in the Usage cell. Change the Usage setting to R.

nd

Q

NOTE:  This cell only accepts the C, R, U, D entries. All other text entries are ignored.

General
Description
Motes
Activity
Properties
[0Rules
Input Sets
Output Sets
Assignments
Links
Usage (CRUD)
Impact Analysis

Appearance

[ Check Inventory &2

™ Task: Check Inventory

Filter Off
Receivers Usage Usage Description
Data Stores
Inventory Database R

+ SE[EE

/‘u/.ﬁ.k\mdfv\L_“vrf‘err\mgj-vud‘\f\‘ﬂwf




12. Using the same steps, change both the:

. “Existing Orders” Usage setting to R, and

. “Orders Pulled” Usage setting to U
Notice that the diagram has been updated with the changes as well.
Your completed diagram should resemble the following:

5 @ @

Ewiting [Orders Inventory|Database Orderd Pulled
R R R
@ Check Order Check Inventory Check Order Pull |a
Start Event Order Filled
TawT
Handle Fault
Fault Resolved
I
Suppliers

Session 17: Collaborative modeling

ER/Studio Repository is the server-side component to ER/Studio Business Architect and
ER/Studio Data Architect that is designed to distribute work across modeling team members in
a safe and controlled way, facilitating a real-time collaborative modeling environment and
increasing productivity for teams. The solution implements utilities and features that enable
concurrent modeling, version management for models and model objects, establishment of
continually reusable data elements, and more. The secure, scalable environment is fully
integrated with the current, natural workflow in ER/Studio Business Architect.

This portion of the guide is intended to give a brief overview and walkthrough of using
ER/Studio Business Architect with ER/Studio Repository. It will start with the install and
configuration of the Repository and continue on to include inserting a diagram into the
Repository, working with the diagram in the Repository, versioning the diagram, sharing and
reusing objects across diagrams and finally applying security to your diagrams. It is intended as
an introduction to the Repository. For more information, please refer to the Repository section
of ER/Studio Business Architect Help or contact Technical Support at
www.embarcadero.com/support.

This session is comprised of the following topics:

e Downloading and installing the Repository

e Configuring ER/Studio Business Architect to connect to the Repository

e Connecting to the Repository

e Adding a workspace into the Repository

e Checking out and checking in a workspace
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Downloading and installing the Repository

To evaluate the collaborative modeling benefits of ER/Studio Repository, you will need to
download and install a separate installation executable. You can download the Repository
installation executable from the IDERA Web site at:

https://www.idera.com/er-studio-enterprise-data-modeling-and-architecture-
tools/freetrialsubscriptionform

You need to download the ER/Studio Enterprise zip file.

ER/Studio Enterprise requires installation on an RDBMS of your choice: IBM DB2 UDB, Oracle,
Sybase ASE or Microsoft SQL Server. Two components will be installed: the server and the
database. The server machine requires the chosen database client utilities to be installed in
advance so that the server can initially build and subsequently connect to and communicate
with the database thereafter.

e For comprehensive installation instructions, including Repository server requirements
and database sizing projections, please refer to the £R/Studio Repository Installation
and Administration Guide.

e Forinformation regarding ER/Studio Architecture, see the ER/Studlio Data Architect
User Guide.

Documentation is available at https://www.idera.com/support/productdocuments

Configuring ER/Studio Business Architect to connect to the Repository
1. Install the server component.
2. Click Window > Preferences.

Preferences [ = i:hl

type filter text Repository Options L=l -

> Business Process Modeling

. Conceptual Modeling Preferences for Repository Options.

. Default Values Server Machine:

> Diagrams Server Port: 54333
: Find/Search

: Formatting

Check out model when checking out diagram: [prompt v]

Idera Licensing

» Import/Export
Messages
Model View
Maming

> Property Views
Reporting
Repository Options

Check out workspace when creating/deleting models: [prompt v]

Workspaces/Models

[ Restore Defaults] [ Apply ]

[ ok || conce |

L 4

3. Enter the Repository connection details as provided by the Repository administrator.
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Connecting to the Repository

To connect to the Repository, click Repository > Log In.

The login dialog will prompt you for a user ID and password. The default login after installation
of the Repository is Admin and the password is Admin; both are case-sensitive.

Adding a workspace into the Repository

1.

2
3.
4.
5

Click File > Open.

Browse to and then open a workspace.
Log in to the Repository

Click Repository > Add Workspace.

Enter a comment if you want to and then click OK to exit the dialog and complete the
operation.

Once the Add Workspace operation is finished, you will see Repository status icons appear on
the workspace objects. Now added, the diagram is available for any users who can connect to
your Repository and who have been granted authorization.

Checking out and checking in a workspace

If the active workspace was previously added to or retrieved from the Repository, you can
check it out.

1.
2.
3.

ol
I:EE

e A

Open a Repository workspace.
Select Repository > Workspace > Check Out Workspace.

In the Repository Check Out Workspace dialog, enter a comment if you want to and then
click OK.

'.q Checked out objects, including the workspace, appear in the workspace explorer tree

with a check mark in the top left-corner of the object icon.

Make some changes to the workspace.
Save the changes you have made to the workspace; click File > Save.
Click Repository > Check In Workspace.

Enter a comment in the Repository Check In Object(s) dialog and then click OK to start the
check-in process.
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Session 18: Using the Web report

You can create a Web report which gives you the ability to visually explore your ER/Studio
Business Architect projects, models, diagrams, and elements via the web browser. You can
generate separate web reports for individual models as well as individual diagrams.

1. From the main menu select Tools > Reports > Web Report and a Web Report wizard

opens. All nodes in the open workspace are selected. For purposes of this example, we will
leave it as is.

i ™y
Web Report Lo | ) ||

Create a Web Report

Generate an HTML report containing information about the current workspace,

Select the projects, models and data sources to include in the report:

a ACME Company
F] @ Compliance Reinstaternent Project
4 [7] & Sales
4 ﬁ Northwind
Customers
Territories
Customer Information m
Customers
Sales Components
Sales Components Part Two
4 m& Shipping Process Model 5

Help < Back Next > By

13

m

L

A

2. Click Next to open the Object Type Selection dialog. Deselect the Shapes objects to
exclude them from the report and click Next.

- Y
Web Report [ | B [t

Object Type Selection
Specify the types of objects to include in the report.

> -ﬂ Business Process Modeling
> ﬁ Conceptual Modeling

s ; External D'ata Objects

» [] [}, Reference Objects

> [l Shapes

Help [ <Back || Net> || Finich

b

A

3. On the Select Report Location dialog, select the directory where you want the generated
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report to be stored. Leave the default setting. The “Launch report upon completion”
option is selected by default. Leave this setting as is, and click Next.

Click Finish and an HTML report is generated for all your selected items. The first page of
the report displays a cover sheet with your report details. A tree containing the workspace
and all projects, models, diagrams, and all elements in the workspace is displayed on the
left side of the report.

NOTE:  You may get a security message telling you that your computer is blocking access to

active content files. Click once in the yellow bar with the warning icon (\Q ) and select
Allow Blocked Content from the menu. Click Yes once again to close the Security
Warning dialog.

You can view properties of objects by expanding the tree and clicking on the object. If you
click on a diagram node, the graphical representation of the diagram opens in the browser.

If you click on an object, for example the "Customers" Business Entity object, two tables
are generated, one showing the details; and the second showing the attributes in that
Business Entity.

=
Report Details B
) jcme Company Customers (Business Entity)
= Comphance Reinstatamant Project
= & Sabas
@ customerConcaptualModsl Details
03 ﬁ* Narthmad :Hlunlt LTy~ 1R
E Custornar Informatson
_ﬁ: Customars Attributes
= sates Components {imbomme© D
{5 sates components Part Teo |conoastisne
*. LustomerCustomerDemo E:Mﬂ
* CustormarDemagraphics : S lA
(address
= Customars e
B custamerin :Em
B companyiame :Mﬂm
B cortacshame Cartes
B cortaceritie ietine
B address :'_ﬂ
0 city
D gegion
B postalcode
0 countey
0 phens
L n Fax r
BB Qukgaing Relaticnships
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Click on the Attribute’s hyperlinks to open the page displaying the details for each.

CustomerID (Business Attribute)

Details

IName [Cusbumerw
|Llnique identifier |True
IData type |Ci1ar
|width s

|scale |L‘I
IEI|;||;i|1nalil'_|r [Man:laburr
Bound business element |Nﬂne
|Bound domain [Mone

CompanyName (Business Attribute)

Details

[Name [Companyame
|Unique identifier |False

IData type ['u'ard'tar
width [40

Scale |I:I
[optionality [Mandatory
IBuum:I business element |Nnne

IBuund domain |Nune

Session 19: Using ER/Studio Business Architect tools

As you work on your diagrams, ER/Studio Business Architect offers many tools that make it
easier to find elements, navigate, and customize your diagrams.

Find in diagram

When a diagram is active and open, a command appears under the Edit menu called Find in
Diagram. Once selected, a Find dialog opens allowing you to enter a name to find on the
diagram.

Find S5
Find what: - Find Mext
[] Match whele werd only Direction
[] Match case @ Forward (7) Backward

@

" ’

The Find mechanism only searches for element names on the active diagram. When an element
is found on the diagram, it is selected on the diagram. Direction controls allow you to navigate
throughout the list of matching names on the diagram.
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Search

The Search function works differently than Find in Diagram, as it searches the entire workspace

and then provides a list of the objects that were found. It searches the data itself, not the

element in the diagram.

To perform a search, select the Search item under the Edit menu.

You can search an entire workspace, or specific projects and models. You can also search on
Names, Descriptions, or Notes. The search can be limited to specific types of objects and you

can match case and whole words.

In the example below we are going to search for a pool with the word “order” in the name.

-

e |

(@ Specific projects, models, and data sources:

Search
Find what: Order -
Match case Match whole werds only
Search in IBaLfar
() Entire workspace ® Names

(") Descriptions

a [V Sales
] & Northwind

% Southwind

a4 E« Compliance Reinstatement Project

[¥] & Shipping Process Model
E- Compliance Reinstaterment Project Par

a [VI[ff} Reference Objects
4 [7] &P External Data Objects

< | mn

) Notes

Lirnit results to objects of type

. ﬂ Business Process Modeling
. ﬁ Conceptual Modeling

. ? External Data Objects

» [][ff} Reference Objects

[] Close dialog after search

@

[(NENENE)E

Close

e

4

After you click the Find button, a Search view appears with all the elements that matched the
search. From this view, there are several toolbar buttons available which will assist in locating
the element in active diagram, all diagrams, or the model view. There are also toolbar buttons

to modify the search and filter out the results.

<" Search Results &3

14 results found for 'Order’ - Match Case/Whole Word in Names for Specific Projects (All Elements)

5]

7~

M=o

Name Type

= Check Inventory.Check ... Sequence Flow
[ Check Order Task

= Check Order.Check Inv.. Sequence Flow
U, Check Order.Exiting Or...  Usage

[ Check Order Pull Task

= Check Order Pull.Order ...
Y, Check Order Pull.Order...
&= Check Order Supplier Li..  Link

Sequence Flow
Usage

@ OrderFilled End Event
Order Picking Business Process Diagram
= Order Picking Lane Lane

OE Order Picking Pocl

Process

Description

Motes

Parent

Check Inventory (Task)
Order Picking Pool (Proce...
Check Order (Task)

Check Order (Task)

Order Picking Pool (Proce...
Check Order Pull (Task)
Check Order Pull {Task)
Check Order (Task)

Order Picking Pool (Proce...
Shipping Process Model (...
Order Picking Pocl (Poal)
Order Picking Pocl (Pocl)
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Element grouping

This feature provides the ability to group elements together into a single entity that can be
moved around a diagram in the Diagram View. Once items are grouped, a bounding box
appears around the group items. The grouped elements move together in a block and are
essentially “locked” together, movement-wise. The Ungroup feature removes the grouping
and allows the elements to be moved separately again.

1.

Select the elements you want to group by clicking and dragging a box around the selected

items. You can also select each item by doing a Ctrl+click on each element in the diagram.

Right-click in any of the selected elements and select Grouping > Group. This command is
also available on the Alignment and Layout toolbar and on the Format main menu.

A bounding box appears around the selected elements.

Place the cursor on the bounding box and the cursor changes to the move cursor ('%').

Hold down the left mouse button and move the grouped items in the diagram.

NOTE:  You can move elements within the bounding box. Click on the element you want to

move and handles appear around the element. You can then move the selected
element within the box.

Diagram commands

There are four commands available under Diagram on the main menu that you can use to
customize your diagrams:
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Case Shift: You can set the default case shift for all element labels. You have three
options:

o Lower: All text appears in lower case lettering, including the initial letter of the label.
o Preserve: Text appears as entered.

o Upper: All text appears in upper case lettering.

Grid: When working in the Diagram View you have the option to display grid lines in the
view. You also can ‘snap objects to grid’ so that when you place an object in the
Diagram View, it automatically snaps to the nearest grid line. When an element is
moved, it also snaps to the nearest grid.

1. With a diagram open in the Diagram View, select Diagram > Grid > Show Grid
Lines from the main menu.

2. Select Diagram > Grid > Snap Objects to Grid to activate this feature. This feature
is active even if the grid lines are not displayed.



e Layout: You can set what type of connection style you want to use: curved, straight or
elbowed. The default setting is curved. When you change this setting to straight you get
a Change Diagram Layout dialog, warning you that this selection overrides any changes
you have made to individual relationships.

e Connections: Show or hide all connections: associations, interactions, line shapes, links,
message flows, relationships, and sequence flows. The available items on the list
depend on the type of model, either Business Process or Conceptual.

Zooming
From the main menu select View > Zoom Level to adjust the zoom level of any diagram. You
have several different options available:

e Fit to page: Zoom level is reduced in the Diagram View so that the entire diagram fits in
the visible screen area.

e Custom Zooming: Lets you custom zoom into and out of any Diagram window by
specifying a zoom percentage on the custom toolbar. The custom zoom feature lets you
type a specific zoom percentage.

e Zoom with preset percentage: You can enlarge or reduce a diagram using a preset
percentage.

Toolbars

e Layout and Alignment: Use this toolbar to align, evenly distribute, evenly size, stack, or
group the elements in a diagram.

)
"]

el HLlE @B D
e Formatting Toolbar: Use this toolbar to: (1) select font style and size; (2) format and
justify text, (3) change the colors of both elements and text; and (4) align text in an
element.

Arial |9 B I 5 UA-A-&-=

= ﬁ- ﬁ.r

Overview Window

This is a 'thumbnail' view of your model and is useful when working with large diagrams that
appear on more than one screen. You have the ability to pan the entire model. As you move
the blue shaded box in the Overview window, the portion in the highlighted area appears in
the Diagram View. Also, if you click an object in the Overview pane, that object appears in the
Diagram View.

g Overview &3 |

f'f.i‘[i?im“
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