System Requirements/Prerequisites

From InterBase
Jump to: navigation, search

Go Up to What's New in InterBase XE7


InterBase Developer Edition and Server Edition

  • Supported operating systems:
    • Windows (64-bit, 32-bit):
      • Windows 10
      • Windows 8, 8.1
      • Windows 7
      • Windows Vista
      • Windows Server 2012, 2012 R2
      • Windows Server 2008, 2008 R2
    • Linux (64-bit, 32-bit):
      • RHEL 7
      • RHEL 6
      • SuSE 11.3
      • Ubuntu 14
    • OS X:
      InterBase XE is the latest release on:
      • El Capitan (10.11)
      • Yosemite (10.10)
      • Mavericks (10.9)
    Note: InterBase XE7 is not available on OS X. See Installing InterBase for OS X for more information.
    • Solaris:
      InterBase XE is the latest release.
    Note: InterBase XE7 is not available on Solaris.
  • Supported processor architecture:
    • Windows, Linux and OS X:
      • Intel x86 or Intel x86-64
    • Solaris:
      • SPARC
  • Hard disk space:
    • Installation files: ~250MB (~350MB for Japanese version).
    • Space needed for install: ~44 MB for compact installation, ~56 MB for full installation.

InterBase ToGo Edition

  • Supported operating systems:
    • Windows (64-bit, 32-bit):
      • Windows 10
      • Windows 8, 8.1
      • Windows 7
      • Windows Vista
      • Windows Server 2012, 2012 R2
      • Windows Server 2008, 2008 R2
    • OS X:
      • El Capitan (10.11)
      • Yosemite (10.10)
      • Mavericks (10.9)
    • Android:
      • Lollipop (5.x)
      • Kitkat (4.4)
      • Jelly Bean (4.1.x, 4.2.x, 4.3.x)
      • Ice Cream Sandwich (4.0.3, 4.0.4)
    • iOS
      • iOS 9
      • iOS 8
      • iOS 7
    Note: The development machine needs to have Xcode 6 or Xcode 7 installed.
Personal tools
Previous Releases:
In other languages